I still can't get Haiku to work on Mac


#1

I’m running a 2011 17 inch MacBook Pro. I had all sorts of issues trying to get the beta to work on it, including kernel panics occasioned by the Broadcom driver. I blacklisted that, panic. Blacklisted the next thing, panic. Then I abandoned the attempt, because I was frustrated enough to hurl the computer against a wall, which wouldn’t have been good for the wall, or the computer.

Anyway, I tried the latest nightly to see if anything’s been fixed. It’s still throwing panics, but different ones this time. Looks like the network thing was fixed. IMG_20190223_2306348

Can anyone help me get to a functioning desktop? At this point, I don’t give a damn if the keyboard doesn’t light up, or if there is no network support at all. I just want to install it on this computer (I’ve been running it on a Thinkpad with good indications)


#2

I’m running natively on MBP 11.3 (mid2014).

  1. try Haiku x64 nightly on USB2 memory stick. This avoids XHCI transmission errors. Use EFI boot.
  2. install bootcamp/windows, which updates EFI with legacy BIOS. Try booting from USB2 stick again after selecting legacy Windows disk icon on powerup. This should work since it uses legacy BIOS.

#3

This appears to be the same as this bug: https://dev.haiku-os.org/ticket/13189

See if disabling SMP in the bootloader helps at all.


#4

Tried it and it does this:15510309500985536587351291035751


#5

I’m already using the x64 nightly on efi boot. I have rEFInd, which provides a “Boot legacy OS” option, but if I try it, all I get is a white flashing rectangle on a black screen.


#6

Ah, now that’s much more useful! Please attach that image to the same ticket, it is almost certainly related.


#7

Quoting Ingo from https://dev.haiku-os.org/ticket/10249#comment:43

You could do a page 0x82cec8e4 and then a cache _cache . If that prints an area, area ... with the area ID as argument, or if it prints a vnode, vnode -p ... with the vnode pointer as argument.

I’m afraid unless you have PAGE_ALLOCATION_TRACING , PAGE_STATE_TRACING , and/or VM_CACHE_TRACING (level 2) enabled, there’s no way to track this further, though.

comment:44

0x82cec8e4 should be replaced with what you see in KDL apparently.


#8

It’s just a regular DOS type cursor.


#9

Sorry I’m late in replying to this thread. I actually did get my 15.6” 2011 MBP running Haiku, but I had done so through a disk swap and MBR boot. I did not have sound, wireless, or any backlighting control for both the keyboard and display, however. And the display was stuck with certain resolutions only. But I hadn’t run into the KDL problems, thankfully.

What happens if you boot from a MBR disk with just Haiku (which should force the Mac to boot in CSM)?