I ported tuxpuck :)

Hi,
I wanted to try porting some software not written by me, so today I tried porting tuxpuck and succeeded :slight_smile:
This is an old school opensource game that I used to play during my teenager years. I was able to build it from source by just adding a #define (don’t worry, it can be wrapped in an #ifndef).

Some screenshots:

Now I’m going to read up on how to build the recipe and send it to the haiku repository :slight_smile:

24 Likes

I’m going to use this thread to ask some hints for the recipe.
In BUILD_REQUIRES I’ve specified
“devel:freetype$secondaryArchSuffix” and “devel:libVorbis$secondaryArchSuffix”
but it says that these dependencies could not be resolved.
I doublechecked and they are both presents in haikudepot (freetype_devel and libVorbis_devel).
Any hint please? thanks a lot.

The freetype requirement should have a ‘lib’ prefix devel:libfreetype$secondaryArchSuffix

Have you tried to build any other packages using these libraries? Are you using the --get-dependencies option to haikuporter? Are you building on 32 bit or 64 bit? It might help to see the full recipe you are working on.

2 Likes

If I encounter a wrong dependency in a recipe I mostly open the mentioned package with Expander, in there it will list the PROVIDES for lib:* and devel:* (packages), this way you are sure there are no typos made. :slight_smile:
Good luck, looking forward on testing it, remember it from long ago :smiley:

1 Like

And the libvorbis one should be all lowercase: devel:libvorbis$secondaryArchSuffix

1 Like

@Lrrr @Begasus @PulkoMandy thank you everyone. I wan’t using --get-depencencies, so this was the issue (plus the ‘lib’ prefix).
Now I’m having a compilation issue while building from haikuporter, it can’t find ft2build.h. I noticed that hakuporter installs freetype_bootstrap instead of freetype_devel, maybe is this the issue?

When this issue will be fixed, I think that I’m ready to send a PR.
Thanks

It probably uses the old detection for freetype, some patches are around at haikuports, one of them being:

@Begasus sorry for all my noob questions. I tried to build from source again and it compiles fine. So I get that ft2build.h error only when building from haikuporter. Also, I wasn’t able to find any reference to freetype-config in the makefile. Any other idea? Thanks a lot.

EDIT: After closer look at the terminal, I see “pkg-config command not found”, uhm…

So you can add that to your BUILD_PREREQUIRES and it will be found then :slight_smile:

1 Like

Thank you, it was “cmd:pkg_config” (the dash in pkg-config is replaced by ‘_’).

1 Like

PR is now live: Tuxpuck: add recipe by Luca1991 · Pull Request #9184 · haikuports/haikuports · GitHub

2 Likes

Review done, left some comments there, at least some changes are required, other then that, nice work! :ok_hand:

2 Likes

Thanks @Begasus I applied the proposed fixes and updated the PR.
I wasn’t able to reproduce the reported high cpu/ram usage bug tho, I have attached some screenshots in the PR.