I can't install Haiku

I have tried to install Haiku from a USB pendrive, but it stays on the screen showing the logo and icons, with none of them lighting up. It doesn’t respond to any keys and I can’t do anything.
My computer is an ASUS D940MX.
Thanks in advance.

You could try booting into safe video mode: Boot Loader

Yes, I tried that option (safe boot). Nothing.

Thanks, Begasus.

Can you enable debug mode and start then tell us where it “stops” Screenshot

Hi Paradoxon

How do I activate debug mode? In the BIOS I don’t have any option like that. And the flash drive with Haiku boots directly to the Haiku screen, where the installation stops and does not respond to any key.

I have tried to install Haiku both on my ASUS computer and on an iMac, with identical result: it does not install.

Thanks so much.

Press space bar after booting fromt he stick have startet. There are the boot options.

Thank you Delldorin.

The startup stops with the following message:

PackageVolumeInfo: Load01dStates(): failed to open administrative directory: No such file or directory.

The administrative folder is here: /boot/system/packages/administrative

Sound like the image of your haiku system are broken. Is it a nightly or beta3?

it’s beta3, downloaded from Get Haiku! | Haiku Project

I burned the iso with balenaEtcher in Linux on a pendrive.

Sounds like a problem like this: #17369 (Nightly build hangs at boot) – Haiku (haiku-os.org)

But on the beta i never hear of this problem. @PulkoMandy can you help out here?

Thats not the real reason for the hang. Try to boot a nightly image.

I downloaded hrev55993 nightly image and had the same problem.

Did you enabled all save options?
Can you try it different use port?
Sounds to me like didn’t recognize the Haiku USB drive? But I can wrong :).

I do not have any option to save the selected options. For example, after selecting safe mode, I will continue with the boot.

I cannot select a different port. I only have Display Port cable, not HDMI.

I don’t think it doesn’t recognize the flash drive because I get the options and in the safe mode menu, under the option to disable components, the directory structure, etc. appears.

I would try a different USB stick, for unknown reasons some combinations of PC+USB port+stick do not work well together

1 Like

I have tested with two pendrives, one with the Beta3 and the other with a nightly image. Both have failed.

USB port was meant, did you try another USB port?

Hi korli

Yes. I got the same result.

The bootloader menu works before any driver is loaded.