Hyper-V Running Haiku successfully but no networking available?

I managed to get the new Release 1 Alpha 4 running in Hyper-V, but when I opened the networking control panel everything is greyed out?

My Hyper-V instance does have the native Network card set as its Virtual Switch so I was surprised when Haiku didn’t allow me to configure or use it?

Is networking enabled in R1A4 or is it disabled, I had a quick rummage through the documentation, but didn’t see anything about it being turned off?

Other than networking everything else seems to be working OK.


Siv: I could imagine that your Haiku instance might not be recognizing your adaptor. Which NIC have you assigned to your Haiku instance through Hyper V? Did you have Haiku R1A3 working with Hyper V? Have you previously used Haiku directly with your native NIC? I’m using R1A4 to write this comment … so networking is turned on :slight_smile:

I don’t play around with Hyper V … and don’t have Windows 8. I’m no expert, but I know that Microsoft supplies special “optimization” packages for the various Linux distros … which could indicate “issues.”

  • Ron

Sorry for my late reply, I thought I would be notified if anyone responded but clearly not and I just checked back in today to see if there had really been no replies to find yours here!

With Hyper V when you create a Virtual Operating System Instance in it’s settings you specify what is called a “virtual switch”, basically this is a mapping to your host computer’s network card which in my case is a TP-Link PCIe Network card which WIndows 8 identifies as a “Realtek PCI GBE Family Controller”.

I have created a Virtual Switch based on this network card and it works OK for all my Windows virtual machines.

When I call up the Network adapter details it says:

Adapter: no adapter
Mode: disabled

All the other options are just empty boxes (IP Address, Netmask, Gateway, DNS #1, DNS #2 and Domain).

So I probably need to know how I make Haiku see it?


Most Virtual Machine software lets you emulate a diffirent network chipset thus hiding the real hardware away from the OS running inside the VM.

You should check to see what hardware your VM will let you emulate.

What you have right now, almost certainly, is a situation where Hyper-V expects the guest OS to use its hypercall system to access virtual devices which were custom designed for high performance within a VM, rather than pretending to have some specific PCI device which doesn’t really exist. Fast virtualisation platforms all use such hypercalls, but obviously that only helps if your guest OS is aware of them and can make use of them.

On a modern Windows or Linux system the OS detects the availability of this “VMBus” via ACPI, and provides a suitable driver to make the hypercalls, then configures networking and storage to use the VMBus and thus get very good performance as a guest OS with a simple built-for-purpose driver.

Haiku obviously doesn’t have anything like that. So to get Haiku working you need two things: Hyper-V needs to be reconfigured to provide a “legacy network adapter” for the Haiku VM instance (which you can probably read about in the help for Hyper-V). Then Haiku needs to have a working driver for the emulated PCI device, which I understand to be some sort of multi-port 100Mbit DEC “Tulip” PCI card of the sort many servers had 10-15 years ago. It seems like Haiku has drivers for related hardware but perhaps not this specific card.

So, even if it doesn’t Just Work™ switching to the legacy network adapter should get you closer.