HTTP Proxy Settings in Haiku so as to access Internet

I am new to Haiku. I am running Haiku in virtualbox (it’s nightly image).
In order to install webpositive, i am using installoptionalpackages cmd, but is not able to resolve the host name.
I’m an undergraduate student and university provides us internet via proxy server . Can anyone tell me how to enter HTTP Proxy settings in Haiku and bypass some of the proxies??.
I am a linux user as well, in linux we have bash.bashrc, apt.conf and wgetrc to enter the proxy settings(username and passwords). Is there anything similar to it in Haiku.

Well, I’m not sure how helpful this is, but if you’ve got bezilla loaded I know you can adjust the proxy settings in the options, but if you are using vitualbox I just assumed that it was proxy aware in of itself. My guess is that terminal needs unobstructed access to the internet to do it contact with the servers (I think you already knew that). No answers really, just random thoughts…

Have a look at the troubleshooting chapter of the VirtualBox guide. It sounds as if this is a network driver error.

I’m able to access internet via Firefox in haiku but i’m not able to ping from terminal. I have set the http_proxy environment variable.

Yes - this was a crazy place for me to put a WebPositive user-agent related comment. Sorry folks. Now with my eyeglasses in place, I have put a better worded version in the General Discussion forum. Even that seems like the wrong place for this (sort of) developer related message, but the developers want only mail-list correspondence. I’m not running my own email server at the moment, so I don’t want the volume that comes from the lists. So - oh well, I hope that a developer reads the one I put into the General Discussions forum, and leaves a back-comment. (Tell me to go away, etc)

I thought about submitting this as a bugtrack item, but I’m not sure that it is one. I love Webpositive for its browsing experience. It’s just excellent, and has never crashed for me. “Great work” goes out to the development crew! I pointed it to various test sites, to check such things as HTML5 compliance, javascript, speed, etc. It does OK in those ways, except that the test sites usually think it is Google Chrome that I am using, when it is really Webpositive, based upon the user-string it generates. Now, maybe that is the intent? The string that comes out of Webpositive is:

Mozilla/5.0 (compatible; U; Webpositive/533.4; Haiku) AppleWebkit/533.4 (KHTML, like gecko) Chrome/5.0.375.55 Safari/533.4

Safari identifies itself as:

Mozilla/5.0 (McIntosh; U; OS-X; en) AppleWebkit/533.4 (KHTML, like gecko) Safari/533.4

Chrome as:

Mozilla/5.0 (Windows NT 5.0) AppleWebkit/533.4 (KHTML, like gecko) Chrome/22.0.375.12 Safari/533.4

Firefox as:

Mozilla/5.0 (Windows NT 6.1) Gecko/20120716 Firefox/15.0

Why is the “Chrome” identifier included in WebPositive? Does Webpositive use some portion of code that is Chrome specific? I think that Google Chrome wants to be seen as either gecko or safari, in order to be accepted by sites. Safari is trying to sneak in as gecko/firefox. What does Webpositive want to do? Mostly those other strings are putting the name of the browser at the end, or near to it, depending upon how they want to be perceived. For instance, Google Chrome wants to be seen as Safari.

Maybe a good string would be:

Mozilla/5.0 (compatible; U; Haiku) AppleWebkit/533.4 (KHTML, like gecko) Webpositive/533.4;

Maybe the idea is to throw all of the browser names into the string, so that all sites will accept the browser? I think WebPositive should carve out a niche, and be itself. Or, let the user change the user-agent … maybe …

The user-agent string is a joke, of course. In the old days, the first thing after the “Mozilla/[version]” was “([system and browser info]) ([rendering platform]) extension” … but recent strings demolish that formatting idea pretty badly. The www consortium should have put a new RFC out on this (the original is also a joke), but all they want to do is complicate it beyond belief with “accessibility” issues.

I suggest you to try loading bezilla because it will allow you to set proxy settings easily.