Hrev54010 won't "git" going

I was able to download the first set files with “pkgman install -y mtools cmd:python3 cmd:xorriso”, but upon trying to run “git clone”, I got a nasty crash error message with some options. Here is the debug output, but the core file is 60Mbytes in size.

Debug information for team /boot/system/lib/git-core/git-remote-http (591):
CPU(s): 8x AMD FX-Series
Memory: 7.98 GiB total, 408.90 MiB used
Haiku revision: hrev54010 Mar 25 2020 06:22:43 (x86_64)

Active Threads:
thread 593: team 591 debug task
thread 591: git-remote-https (main)
state: Exception (Segment violation)

Hope this helps. If it needs to be submitted to bugtrac, just let me know.

NOTE: This was a consistent, repeatable error. Every time I tried, even after rebooting.

Do you tried to update git (pkgman update git)?

1 Like

Git was broken after openssl update. Updating it (git) will fix this issue. Also, when you open debug report you should wait for debugger to finish writing debug report, this one is incomplete. Core files are rarely needed.

1 Like

Yeah, I was thinking it was a fault of the latest revision (54010) of Haiku, so I installed the revision I have on my HP laptop (53971) and it still happened. So, it wasn’t the revision, thankfully. And the fix is real easy, too.

So, when will the fixed git make it into a revision, so it doesn’t need to be “patched in”, as it were?