HP Pavilion PC not booting properly

Hello there,
I was trying to boot a HP Pavilion from a thumb-stick with Haiku on it, and I got a black screen with a blinking Num-Lock key.
I have been able to successfully boot it on a Lenovo idea-pad before, but It doesn’t seem to be working with the HP.
Any ideas?


Try the failsafe video mode. To enable it you have to press the space bar right before the Haiku boot screen appears (if you boot from BIOS, it might be different from UEFI, not sure about that) to get to the bootloader menu. There you can choose “Use failsafe video mode” and continue booting.

If that works you can make it permanent as explained here:

1 Like

I booted the Lenovo and using the link, set the settings to always use fail-safe video mode.
Then I tried booting it up on the HP and got the same problem. It showed absolutely nothing except for the blinking num-lock key. I tried holding space bar, but it still did not respond.
I appreciate your help!

Is the thumbstick just the anyboot ISO or an actual install? Presumably you mean the latter, but it isn’t clear. Have you tried booting in Legacy/BIOS compatibility mode as well as with “full” UEFI?

Was the HP Pavilion pc working fine before? Because that sounds like some kind of hardware fault condition. You might try a hard reset (see HP support pages for procedure) and see if that helps. Usually it involves

  1. disconnecting all peripheral devices, the battery, and the PSU
  2. holding down the power button for 30 seconds
  3. reconnecting the AC power (and battery?)
  4. starting up the computer
1 Like

Haiku is installed on the thumbstick as if it were a hard drive.
I have tried booting in legacy mode. The one thing I’m not sure about is UEFI. When I got into the BIOS, it showed the thumbstick right under the hard drive.

The HP does work fine; it runs BSD. I’m using it right now to type this.
Another thing I should mention, is I have been successful in booting the HP from a thumbstick with a different OS on it. Also, the HP is not a laptop, so it uses an HDMI monitor. I think I might try to boot it one more time and take pictures of what the BIOS shows.

Thank you for your reply!


Assuming the install boots fine elsewhere it’s probably okay.

FWIW while BIOS (Basic Input/Output System) is technically a generic term, a distinction is made between code conforming to the previous “standard”, which is called BIOS, and the replacement with newer software which conforms to the UEFI (Unified Extensible Firmware Interface) spec which is usually called UEFI. What’s important to the user is whether you have it configured to boot into a mode compatible with software expecting the Legacy BIOS or in a native UEFI mode. Sometimes tutorial and information refer to CSM (Compatibility Support Module).

What you initially described does sound like a video/graphics card problem. Are you using integrated graphics or a discrete card?

Do you know which particular release/nightly hrev you have installed on the thumb drive? If there’s nothing critical on there you might try reinstalling with a newer version.

1 Like

Here are the pictures of the boot order and boot setup.DSC06246 DSC06247 DSC06248 DSC06249 DSC06250 DSC06251 DSC06252

As you can see in the second pic, “KingstonDataTraveler 2.01.00” is listed under “legacy boot sources.”
Once I selected that option, all I got was the third pic: nothing.
The rest of the pictures show how I have the BIOS set up.

What I thought at first was that Haiku just did not talk to my monitor. But then I started to doubt that because after a while of black screen, it quit trying to boot into Haiku and booted into the primary OS.

I have thought about putting the newest version of Haiku on my thumbstick but I do have a few projects on it. I don’t know which nightly hrev it was, but I can check into that later.

I hope these pics will be of some use.

This machine has integrated graphics.

You could put the stick into another machine and update Haiku using SoftwareUpdater or pkgman.

I don’t see anything clearly wrong in the BIOS/UEFI settings as shown.

What I thought at first was that Haiku just did not talk to my monitor. But then I started to doubt that because after a while of black screen, it quit trying to boot into Haiku and booted into the primary OS.  

The above makes me wonder if your USB stick is corrupted/faulty. You might try backing it up and writing a clean install to it.


You said you’d tried safe mode. If that’s all you’ve tried I suggest trying the following other settings separately and together in various combinations. The fail-safe graphics driver is the thing you should try first.

  • Ignore memory beyond 4 GiB
  • Use fail-safe graphics driver
  • Don’t call the BIOS

The graphics mode is set to fail-safe.
The thumbstick works fine on the Lenovo so I don’t think it’s corrupted.
I think I will try those other steps though.

Try going old school with a DVD :laughing: For whatever reason, some of those PCs won’t boot from Haiku on a USB stick but will from a burned DVD, and idk why exactly but it might be worth a try!

Can you tell us the models and general specs of the Lenovo Ideapad you mentioned and this HP Pavilion you’re working with?

He’s clearly using a system with UEFI which means it’s almost certainly relatively modern. Most machines that are less than 10 years old (and some before that) should be able to boot from USB sticks. I had kind of thought that UEFI was usually for 64-bit machines, but idk. Maybe there’s a 32-bit/64-bit mismatch involved?