Hp Pavilion Notebook "B&O" is booting this way

I ran into this issue on my HP Pavilion G6. It was a pain, so I ended up deleting Windows. Try unplugging the power/battery. That way you don’t have to wait for windows to boot and shutdown 3 times. 3 was the magic number on mine too.

On a side note, whenever I do a fresh Haiku install with certain versions, or on certain updates, I seem to have wait for a couple boot time kdls to flush through the system. Each time it will kdl in two different places before finally booting fine until the next install/update.

I do not like this UEFI Stuff…
Before it was easier to boot into Haiku…

1 Like

Same here. I wiped my UEFI tears away when I wiped Windows off my computers. I’ll stick with tried and true MBR and occasionally test UEFI. I’ve got enough headaches.

Are we talking of warm restarts instead of full power-off/reboot cycles?

As no other users seem to currently have this issue, is-it possible that this is particular to the HP Pavilion line?

1 Like

no I have this issues on my Tarox PC as well

I’m assuming it is particular to the HP Pavilion G series laptops. Mine does the same behavior as described by OP. My G6 has several peculiar activities that are specific to it. Crashing while running the Haiku build system in Haiku is one. I can use haikuporter just fine. I can run other build systems in Haiku just fine I can build haiku in Linux just fine. Building haiku in haiku results in a crash every time. Dead lock up, not possible to get kdl or recover the syslog. This only occurs on the G6, no other hardware that I have. The G6 also has a dead lock up on shutdown, but not reboot or shutdown -r. Same no kdl or recoverable syslog. And of course the USB booting misstep noted above.

Hp Pavilion Notebook “B&O” does not work!
Cannot boot into Startscreen…
Will file a bugreport when I got something…30

Is this from a clean Haiku image? It looks like a filesystem corruption problem.

No I used the usb-stick with my other laptop and used SoftwareUpdater with it…
So it is not a clean image!?
Should’nt it work anyway?
I tried a Haiku 64bit USB - Stick
and a Haiku 32Bit USB - Stick
If I do a clean Haiku Image… what is the difference?
What to try now? Make a new USB - Stick with a nightly build? thx for helping…

As I said it looks like this is not an hardware problem but a corrupt filesystem. To avoid that, you can try downloading a nightly build and writing it to the stick, or use a different stick, or check that the stick works on another computer.

Also, when you have bugs, please report on the bugtracker, not on the forum.

1 Like

Actually this message almost always means that write-backs failed and left the block cache in an inconsistent state (i.e. the last transaction is still open because blocks in it were not written due to an error.) The syslog will reveal the real reason. So, actually it does often mean a hardware problem.

I filled a bug report:

Today I tested Haiku R1 Beta 3 nightly 64bit (hrev.: 55467) again on this Laptop.
It will boot without problems now!

Only sound is broken/missing now!
The WIFI is still not working!
Ethernet works.
This is a very fast Laptop (Teapot spins with 1000fps)

usb_audio is already working with USB 3 ports (with some small glitches), but driver currently not included in nightly builds.


The glitches occur at least every 1-2 seconds if not more often for a fraction of a second (i.e. 1/10 or 1/20 of a second). They are enough to make the output totally intolerable in practice, at least on my hardware. They should be fixed before the driver is added to builds (and I haven’t yet gotten around to that.)


I do not know if I have USB-audio at all!?

It is a HP Laptop with no additionally hardware plugged in… (Btw. It is a very slow laptop to run with windows 10!) not so Haiku which spinns the teapot approx. 1000fps!

I will try to use cortex to override the audio_mixer to see/hear if I get sound then…

Interesting, in this bug report audio was working!
[https://dev.haiku-os.org/ticket/14662 ]

It turned out that I by myself blacklisted the hda-driver on my other Haiku install. I cloned this Haiku USB-Stick with BalenaEtcher and so the driver was copied over to the new USB-Stick which I used on the other Laptop!

After deleting the entry sound works fine now on Hp Pavilion Notebook “B&O”!

Sorry for all devs wasted time to look into this issue…


It is booting just fine with UEFI boot as well…
Only WIFI still not working and Webcam