Hp Pavilion Notebook "B&O" is booting this way


#1

Works in Legacy mode!!! with save video mode turned on!
HP Pavilion Notebook
Product Number T1F62EA#ABD
System Board ID 80A5
born On Date 12/24/2015
Intel Core i5-6200U Cpu
2.3 GHz
8 GB Memory
BIOS Version F.61
BIOS Vendor Insyde
Graphic Card GeForce 940M
(Haiku identifies this card as: Intel (Skylake GT2)

EDIT: I can boot in legacy mode with safe video enabled!!!
SDC 17.3" VESA Driver! 1600 x 900 32 Bits/Pixel
In Safe Mode Options you have to use the fail-safe graphics driver!!!

Mouse and Keyboard and Touchpad works! Sound works (sometimes)! No Wifi!!
Ethernet works!!!


Does it have word processing, spreadsheets apps?
#2


#3

Are there 2 Graphic Cards installed?!


#4

How to start Haiku-USB with HP Notebook B&O:

  1. Make a Haiku USB stick (https://www.haiku-os.org/guides/installing/making_haiku_usb_stick/)

  2. Start your HP Notebook (here: HP Pavilion B&O)

  3. press imediately the “Esc” Key multiple times to go into HP Bootoptions (Esc …pause start up)

  4. choose F10

  5. use the arrows keys to go to: ->System Configuration ->Boot Options

  6. Disable “Secure Boot” (Secure Boot -> Disabled)

  7. Clear All Secure Boot Keys

  8. Enable Legacy Support (Legacy Support -> Enabled)

    btw.: Here you can change the boot order of the UEFI and the Legacy boot options! This won’t work by now!

  9. Press F10 to save and restart press imediately the “Esc” Key multiple times
    to go into HP Bootoptions again (Esc …pause start up)

  10. this time choose F09 (Boot Manager)

  11. Choose your USB Hard Drive… (Not! USB Hard Drive (UEFI) - Example ScanDisk!)

  12. You have to be very quick now to see the Haiku Bootmanager!
    Press Shift-Key and hit the Spacebar accasionally (Hochstelltaste halten + Leertaste mehrmals drücken)

  13. You will see/enter the Haiku Bootloader! Choose Haiku and try to be very quick again to enter Haiku Boot options!

  14. Select safe mode options and Use fail-safe graphics driver by pressing the Spacebar or Return Key.
    … go to the bottom with the arrow key and choose Return to main menu…

  15. Choose Continue booting here…

Hopes this helps!?
Now you will be able to test Haiku at full speed!

arrows keys = Pfeiltasten; Shift-Key=Hochstelltaste; Spacebar=Leertaste; Returntaste=Eingabetaste…


#5

Ummm… are you sure you wanted to address it to me?

Btw, thanks for the translation, german technical words are still strange.


#6

I’ve got a ZBook here but it fails to boot. It is stuck at a black screen. Can’t seem to get these boot options to fiddle with it.

EDIT: Boot options now works. But nothing useful. Safe Mode does not help. Even looking at the debug logs does not help. It seems Haiku hangs right before loading the initial kernel modules.


#7

What’s the last line of output; and what CPU does it have?


#8

Hi, did you try to use fail-safe graphics driver?
If not Haiku will KDL after the 4th icon… and you get the not boot partition information?!


#9

It’s a “HP ZBook Studio G3 Notebook i7” to be precise. The CPU is thus an i7 which I think is not too peculiar. Chipset is Intel CM236 according to manufacturer. I run it off USB so the SSD HD should not be the problem.

The last output is a black screen right after booting. When I go into safe options and look at the current logs (there are no last boot logs) then the last lines are Partition::~Partition style lines. It does find the USB partitions (I have three on it, Linux, Haiku and a transfer VFAT one, with GRUB doing the bootloading). Could it be of importance the Haiku partition is the second primary partition?

Anyway, if I continue booting (with failsafe GFX) from the boot options I see the haiku logo but no icon starts to fill as it immediately hangs.


#10

Any ideas how I could approaching debugging this issue? Or rather, what options do I have? I can get into the boot debug screen but not further than this. I can run the same USB Stick on VirtualBox. So maybe I can get the boot process to write something to the USB Stick so I can examine it later in VirtualBox? As this is a laptop serial connection is not possible. I assume the chances are slim to get this working?


#11

I tested 64 bit Haiku on my earlier work-provided-laptop, it was a ZBook G3 17", no idea if it was a Studio one or not.
It sported NVidia Quadro GFX, and booted nicely from USB with Haiku nightly before Beta.
First it KDL’d with SMEP/SMAP, but it got fixed:
https://dev.haiku-os.org/ticket/13984


#12

I updated to the latest again. On boot menu I enabled safe-mode and debug options to print to screen and syslog. Still I get black screen and nothing happens. Something is not working at all and I’m at a loss on how to figure out what it is. Can I somehow get to the logs after hard-rebooting from this black screen?


#13

The bootmenu have option for that. Or use a serial connection.


#14

It only allows me to show the boot-log of the “current” session. I would need though the one from the “last” attempt.


#16

Nope, consult with the docs: https://www.haiku-os.org/docs/userguide/en/bootloader.html


#17

I don’t get this menu with the previous boot logs. What I did now shutting down after crash. Then reboot into another OS. Then boot USB stick with VirtualBox (this works). Then I copied /var/log/syslog* aside. Is this worth anything or useless?


#18

You can use Linux to access (read-only mode) the /var/log/syslog/ files from your Haiku partition.

Boot from a USB drive with some Linux distro (if you don’t have previous experience you can use Ubuntu: is very friendly) and then, your Haiku partition will be “visible” from it.


#19

Got further by now. When I restarted like 3 times I got into Haiku. Looks like the BIOS does not fully like the USB stick and failed properly reading from it the first times I tried. Seems that I needed to restart 3 times in a row with the USB stick in without letting Windows get in between. Strange behavior. The USB mouse and keyboard is not recognized yet but that might be because they are attached to the docking station. Need to experiment a bit more with this stuff.


#20

The system scans for potential boot volumes during the initial boot phase performed by the BIOS - and maybe the EFI as well.

Windows tends to leave bread crumbs on attached volumes even if these are not formally mounted. This behavior would likely explain your observations.


#21

What can be done? Not leaving the stick inside while windows boots?