How well Haiku handle old Intel Graphics?


#1

Hello!
Im trying to run Haiku on a few machines without any luck. Yes, it does work at VirtualBox, but very slowly. :-/ And on phisical machines... Oh well, Im out of luck. One of my machines is old Eee PC 900 with Intel i845, and Ive read somewhere, that Haiku work with it very nice. Ive tried install Haiku x86 on it since a few months, using nightlies, but it didnt work. Ive always finished with that screen:


So Ive tried with other 2 PCs at my work - both are old Dells with Intel Graphics and the same screen came up. I gave up. Some time ago, Ive read (I bielieve it was months summary by PulkoMandy) that someone has fixed Intel Driver and it will work. So yesterday Ive downloaded 64bit nightly at work and Ive been trying to run in on does old Dells - Ive got the same screen as always. To be honest - Im not going to use x86 on my Eee, because I``m back with Debian there, but I would like to use Haiku as main system on my Atom board 525dw with Intel Integrated Graphics, but I guess it will give me the same screen. :wink:
GPU at my work is Intel Q965 Chipset
So does those old Intel Graphics Drivers work for any of you?


#2

Trynwith space key before the haikuboot splash you can set the vga standard in options ththere, i am not sure but while someone better help you, can try with it.


#3

Your screenshot does not look to be a driver problem. First, because when the intel driver does not work, you end up with a blank or corrupt screen. If Haiku manages to show something, it means the driver is working. Second, because it is not the kernel debugger, but app_server crash.

You would need to type “bt” at that prompt to get a backtrace. Then, take another picture so we can see where the problem lies. Try to not crop it as much, so we can read all the information.


#4

It could still be driver related, for example, if it is advertising the wrong frame buffer, or a wrong size of the frame buffer.

In any case, the EeePC 900 used to work quite nicely. I had one in my possession for quite some time, so if it doesn’t run anymore, it’s a regression. Since the Intel driver saw quite a number of changes in the last couple of months, that would actually be quite possible IMO.


#5

I just used other PC for Haiku ATM, but tomorrow Ill try Haiku live on my Eee and if it will work, Ill install it on SD card (I need Linux there anyway to play my Wine games outside).


#6

I’m using a laptop with Intel Mobile 4 integrated graphics and the only way I can run Haiku is to use the VESA driver.

The devs are heroes, but they can’t squash every bug on every piece of obscure antique hardware out there. XD

Hold shift at the bootloader and set the safe (VESA) graphics option and continue the boot, see if that helps. To be fair, performance with the VESA driver is surprisingly good.


#7

Did you just called my lovely Eee obscure and antique?


#8

Well, I was referring to my own hardware, but if the cap fits… :wink:


#9

i have a Eeepc 700 running Debian etch due lasted stupid linuxes are very slower to run all my stuff

in those hardware runs the lasteds nighty builds?


#10

Etch? I thought about that one for me too. Do you have recent browser there? I guess old Firefox don`t work to well with todays www,.

Maybe I would do dual boot Haiku and Etch. Whitch one shoud I install first for easy dual boot?


#11
  1. for all of that, must use Venenux older repo, firefox on etch only up to 16, due gcc/stdlib++ maybe using lenny could up to 28 with hard patches and using gcc 4.5 backported, for more information use the mail groups venenuxsarisari or vegnuli@googlegroups.com , take in consideration that older version are anti-win32 related http://debianeepc2gsurf.blogspot.com/

  2. firts must install haiku, and then install etch/lenny/squeeze, linux/grub can handle beos? rootnoverify is what made it work. Without rootnoverify, BeOS would not boot. so until 0.97 you can doit, in squeeze/lenny grub2 are available/default so rootnoverufy will not are available, must use with manualentry if not detected, using root=(hdZ,X) but scheme numbering start now from 1 event from 0 …


#12

ah i forgotten: here a video running snes9x and connecting to internet by wifi with networkmanager https://www.youtube.com/watch?v=kdm27eyNtmg

i wants to use haiku in this eeepc 700 but seems remote connection are a issue here! i started to write articles about use haiku in that pc/laptop


#13

Aren’t the old Eee’s 32 bit?


#14

Yes. Only 32bit. Eee 900 and below use Intel Celeron 900, and that one is 32bit only. But many Intel Atoms used later are 32bit too.