How to install Haiku to USB Flash Drive from Windows

I could write image to my PNY Flash Drive using flashnul but never could get the motherboard to boot it. Yes, the boot order was modified to accept the USB Flash. It indicated “missing operating system”.
I cannot rule out the flash drive itself being the issue. This may require testing with different makes. This is a very cool means to boot up, for those it works with. I expect with more to come that compatibility will be improved too.

mixed results.the flashnul works fine.

I can boot USB, as proven thru the HP util.(HP key disk,available somewhere)
no luck so far.will try again with usb.definetly no luck with native hard drive.

If you want to use Flashnul under Windows Vista you wont get the list of the “available physical drives”, but the “available logical disks” only.

So, go to Windows Menu > All programs > Accessories and make a right-click on “Command line” then select “Run as Administrator” (or something like that, I’m on a french version of Vista ^^)

Now, you will be the Boss in your House and could use Flashnul :slight_smile:

Well, I’m glad to see Haiku booting from a “noname SD Card” plugged into a “generic USB Multicard Reader”!

Running on an Asus P5B+E6400+3GB
KDL said to me “page fault, but interrupts were disabled”.
Even when playing with different boot options like “Don’t call the bios”, “Disable IDE DMA” and so on, the better I can have is stopping on the fourth icon of the BootScreen.

Running on an Acer Aspire 5683 T5500+3GB
KDL now say : “did not find any boot partitions” … after the fourth icon as well.

Running on a Compaq Armada E500 PIII+512MB
Hey, this old machine can’t boot on USB!


Thanks :wink:

Tried on a MSI Wind with no success - didn’t seem to want to boot off USB stick.

Hi. Good text miglas :wink:
I have mainboard Gigabyte M61PME-S2 for Athlon X2. I made all according to recipe. In BIOS I have boot options: USB-FDD, USB-HDD, USB-CDROM, USB-ZIP. I checked every possibility - pendrive is visible during boot - but computer booting with HDD. Someone checked on this mainboard?

I think the developers now require one to run a makebootable program on the partitions (like Apple’s “blessed” system folders). I don’t think anybody’s going to run these new versions unless someone ports makebootable to Windows.


No, it’s not like that…

Basically the first block of a BFS partition has some “magic” in it that stores the physical offset to the partition in relation to the start of the disk. Whoever formats the BFS partition is responsible for setting this magic value (i.e. if you were able to use gparted to create a BFS partition, it would do this trick for you… but unfortunately it doesn’t support creation of BFS partitions).

The problem is, dd’ing a BFS partition from one partition to another is actually a bad way to make a BFS partition. This is why you must then run “makebootable” on the partition which fixes the offset and allows the bootloader and kernel to locate the partition again after being bootstrapped and load all the drivers.

I have run into funny situations where I dd one BFS partition to another, but booting off of the second partition really goes back and reads the first partition. This is because the second partition has an offset pointing to the first partition still, and if the first partition is still there and valid, it will be used by the kernel.

The reason dd’ing a raw image over an entire disk works is because this overwrites (removes) the partition table, making the offset accurate because the image starts from the very beginning of the disk.

Personally, I doubt that’s gonna happen. More likely you’ll see Haiku LiveCDs that can format BFS partitions and make them bootable before this happens :slight_smile: If you can boot a BeOS or Zeta LiveCD and physicall access the partition - that can also do this trick.

HTH, not trying to be a pain, just trying to explain what’s going on.

not quite.

ZETA boots okay, if you use SAFE mode and switch from german to english.(unless yer german…)

They removed the hd utils, so you have to bring them in from haiku or senryu.yes, i’ve tried this going the other way apparently there is a make boot floppy script the team forgot about.its in the ‘bin’.

my issue, since I have only usb floppy is how to write this disk from within haiku, since haiku cant boot natively and wont list the usb ports like Unices i usually use.maybe if ZETA makes the disk, i can do it.

I’ve had no luck trying to boot haiku off a BeOSr5 boot floppy or cd.It just hangs after completion.I can get R5 to load, but I only have usb kayboard and mouse, so its useless.
(still need safe mode)

makebootable is supposed to do the magic, it attempts to work. you can make a BFS partition and format it,even copy over install (by either senryu installer or the ‘cp’ command), but booting it natively is next to impossible.(EVEN with makebootable)

see, you design an OS UP FROM the bootloader, not the other way around. until lilo or grub can boot haiku (BFS) like thay do linux, I HEAVILY DOUBT Haiku, Senryu, or ANY derivatives will boot natively. RC or not. you can write and read BFS from certain linux distros, forget which, as i’ve encountered seven different ones trying to reformat my ibook to something semi- as fast as os9.

I found knoppix works quite well at similar speeds for my tower. see it isn’t just about doing the job, its about how WELL you can do it, and this was where R5 shimmered.If its anywhere NEAR the speed of knoppix on this machine, I’d buy it in a heartbeat. IF WE CAN GET IT TO BOOT.

the creators that built the disk images just assume like any programmer, that the app works both inside AND outside of Haiku, when in fact, makebootable only runs properly from a ubuntu install with haiku sources.its like assuming a windows(32 bit enviroment) app will run flawlessly on dos (16bit).you BETA and ALPHA test for a reason.I like what I see, but i think yall at Haiku can do better or look for another alternative [bootloader]that can do the job much better as far as getting this to a consumable product.

without that, lets face it, you have nothing.

the cracking team for osx86, (even if it is a grey area) found an opendarwin bootloader that sure yall can find something.

in the meanwhile, enjoy the curio.


I just bought an old p3 from ebay so I can enjoy BeOS in a semi-native setting. I have a keyboard/monitor switcher so it should be fun. I don’t think my dual-core amd turion is ever gonna work this out “magic” boot-sector or folder or grub or lilo or usb or partition or ubuntu or anything (most of which I’ve tried).


Warning, what follows is borderline rant, and to make it worse, it was written in between other things I was working on, so it’s somewhat disjointed.

Take it with a grain of salt, and please excuse my broad ignorance of the details. Sorry if it offends.

[quote]I’ve had no luck trying to boot haiku off a BeOSr5 boot floppy or cd.It just hangs after completion.I can get R5 to load, but I only have usb kayboard and mouse, so its useless.
(still need safe mode)[/quote]

That’s because Haiku is not BeOS R5. The bootloader and kernel need to be built from the same source repo - as they’re tightly coupled. There is actually a set of information passed from the bootloader to Haiku’s kernel when it’s bootstrapped. This is not meant to be compatible with BeOS. You would likely run into a similar problem trying to boot a new Haiku partition using an old boot floppy from Haiku - as the bootloader wouldn’t be passing the right structures to the kernel when it’s loaded (they have changed over time).

I not entirely sure what you’re talking about here… Last I heard, Haiku couldn’t properly partition or run makebootable from itself - so if that’s what you’re complaining about, that’s simply a known bug still. Of course, maybe that was supposedly fixed, I don’t know, but I doubt it.

That seems awfully opinionated to me. I don’t have any problems booting Haiku from Grub - in fact it works every time I try it - but, all it does is chainload to the Haiku bootloader on the partition.

If you want a version of Grub that boots off BFS, go use the one from SkyOS. Haiku doesn’t use Grub, and doesn’t intend to.

Now, if you’re complaining about Linux or Windows support for BFS (or lack of support), maybe you should take that up with them. At this point, Haiku aims to be an independent OS, and therefore it will be able to install and boot itself without any other host OS, or bootloader-helpers… seems like a good strategy to me.

So maybe we can set the record straight: I don’t believe the creators of the disk images expect “end users” to actually use them. They’re there for testing and development. If you can’t figure out how to make it work, then it’s probably not ready for you yet.

When Haiku is released as alpha/beta - I’m pretty certain the plan is to provide a bootable CD that can partition and format a disk.

This insinuation that Haiku’s developers must somehow cater to every possible scenario at this stage of the game bothers me personally. It’s not like they don’t have enough to do already.

If you’ve tried everything you’ve found and read, and still nothing works for you - then likely your configuration simply doesn’t work.

One final thought - posting your issues, concerns, and questions here is not likely to get much attention of the developers. If you’d like development review of your issues, you should file bugs in Trac, or post to the development mailing list. The forums are mostly frequented by other users of Haiku.

Good rant. Agreed.


believe what you will.rant all day if you want.

the problem lies with makebootable.

as far as not using grub or lilo, BEST OF LUCK TO YA!

only reason it MAY be required is because makebootable doesn’t natively work. maybe if you built from sources it MIGHT.maybe.
hence the need for lilo or grub.why it works in HAIKU in a VM i couldn’t tell sure there is a difference somewhere.

there is an installer, you have to grab it from SENRYU, your offshoot.ZETA doesnt have it, they removed it on purpose.

The BFS formatter is in Haiku, you need a blanked drive to use it or it wont work right.use the disk utility.size is the only thing misreported, it only reports the correct size on a created VM image that is blank.
otherwise, it works.

copying the files with -R also works.

good tip on R5, though.question is could you modify the R5 to get HAIKU going assuming the bootsector is all you kept?there has to be a way to raw read or hex edit the R5 floppy.

beta code doesnt mean jack if you cant test at least the base of what you are coding for.(which means booting natively, even if old hardware is all you designed HAIKU for.what good is an os that wont boot?) anyone?

didn’t know it actually worked with grub, i was too busy fixing knoppix.aparently even with the speed increase, the apt-get doesnt grab the proper files for the release and has a habit of grabbing experimental files instead of unstable/testing.

will give haiku sources a whirl AFTER i get this system a little more stable.some of my packages are being removed when they shouldnt.i look for stability first in an OS, then speed.

knoppix and Haiku have both.

No luck apart from one PC, that I have got it to load to the last icon 'till it freaks out, debugger says about it: :busy bit not set after 100ms - probably noone there :aborting because busy bit not set"

BTW the boot options: USB-FDD, USB-HDD, USB-CDROM, USB-ZIP don’t do anything in this case, don’t bother to try and use them, if your computer can boot from USB pen drive then the BIOS will be tricking its self into thinking that its a local hard drive, so rather go “hard drive boot order”, and use the num pad + & - to change the boot order.

OR if you have a Esc or F12 boot select the use that. Mine has a list that looks like this:


selecting +HDD

brings this list


what piss’ me off is that the PC that is dose work on (AMD sempron 2.6Ghz socket:754) the motherboard doesn’t always see it and that it takes a bit of fiddling, removing, turning the computer off and on then putting the flash drive back in and trying again.

I had to enable USB Legacy Emulation to use USB booting on my laptop but it it KDL’s now saying it can’t mount boot partition, oh well.

Hi There!!!
I have a problem while booting haiku, i followed the guide and flashnul create a bootable pendrive about 400 mb.
when i boot up, in loading screen haiku returns an error:

PANIC: vm_page_fault: unhandled page fault in kernel space at 0x80465165, ip 0x8045ef00
Welcome to kernel Debugging Land…
Thread 13 “main2” runnig on CPU 0

this is what happens on my msi wind u100 with double boot winxp ubuntu 8.10
can you help me?

If You got the bootscreen i think the disk is correct. Maybe this is a bug in the Haiku. Can You try the booting on an another machine?
If it works on an another computer, please, serach on the for the duplication, and if You don’t found this problem here fill an bugreport.
Thank You, mastermind.

What icon was haiku under when the crash happened?
what revision was it ? (i.e. say r28555)

And also when you get to the Debugger enter bt or sc, You may want to take a photo of it.

And also yes, do go to