How to burn Haiku OS?

Hi everyone,
I’m out of ideas! And so is Haiku documentation! I tried to burn alpha4 on a USB stick using Refus, etcher, and Haiku_on_stick, they all do the same, which is using DD style to format my USB stick, which - unfortunately - my laptop can’t boot to, so I bought a CD, I used Imgbrun on Windows which didn’t succeed, then I bought another one but I used K3b on gnu/linux this time, SUCCESS! I saw the splash screen, but then it says “welcome to kernel land” and “kdebug >” then it expects me to write something.

any ideas, please?

Edit: probably what caused the CD not to work is the fact that I used the anyboot image instead of .ISO, I will download .ISO then try again.
Edit #2: no, won’t work, it says kdebug and waits for an input.

I strongly suggest to try a recent nightly image instead of the very old alpha4.
And please don’t use bold font for your whole text. :slight_smile:

1 Like

Hello, and welcome! :slight_smile:

Did you tried to create the USB with the ImageWriter app?

I used it in the past, and worked well.

Also, I also think that is better if you get some nightly image. In the recent nightly you will get the package manager, and could update Haiku, without need to burn a new CD or USB.

Please, tell us if you had success with it.

1 Like

Thanks humdinger! the latest night build has passed the drivers step (which caused the alpha4 to show the “debug” thing)’

but is it normal to take over an hour to boot? I’m using a CD, I been waiting for this splash screen to finish for an HOUR!

**I use the BOLD font because I care about your eye-vision :innocent: I don’t anyone to stress his/her eye :slight_smile: **


Thanks :slight_smile: un_spacyar

Win32imager also uses the “DD style” thing, so, I can’t boot from it.

P.S.: don’t suggest win32imager to anyone, I used it a month ago with PC-BSD, and it caused my 16 GB USB flash memory to turn into 2 MB!! I had to try so many solutions for weeks until I finally found it, and I’m not quite sure that it works 100% as it should. :disappointed_relieved:


Please don’t use bold, really. We have set the forum the way we want it to render, and if people want bold or bigger text, they can do it themselves in their web browser.

Use bold only for important parts of your message.


1 Like

Hello and welcome,

what notebook you use, model, type and so on ?

My best solution in all cases is, disable “Secure Boot” in the notebook BIOS. Disable also “UEFI” in the notebook BIOS. If nothing works, turn of “USB3” in the notebook BIOS.

1 Like

it’s an Acer Aspire 3050.
It doesn’t has an UEFI, so I don’t have to worry about secure boot or any of that, nor it has USB3.

I been waiting for Haiku to boot for an age, any ideas?

Hello Ayman. Just to check: did you unzip the file before trying to create the USB?

In any case, on this weekend I will try to create one. I didn’t burn a Haiku since several months, and maybe I’m forget something :slight_smile:

umm, why are you asking? is it wrong to unzip it?!
anyways, when I used Haiku on a stick, I didn’t unzip, because the program says that it needs the zip file, but when I tried with different programs like “Refus” I unzipped.

I will try to burn the the latest .iso file available though this link, if I didn’t succeed, I will give up :cry:

It’s OK to unzip the file when using the Image-Writer or the DD comand from Linux (you must create the image from the .image file).

I officely give up :disappointed_relieved: I tried many times until I was able to get the CD to boot, but was stuck in the splash screen, it won’t pass it, despite the fact that I waited for 5 hours, it’s just keep loading.

I guess I will have to wait untll Haiku moves forward a bit more.


Your ATI Radeon Xpress 1100 chipset is unsupported in Haiku.
There are a couple of tickets in trac for this incompatability:
You’ll probably have to use fail safe video mode, which is set from the boot menu.
Hit space bar while booting to get into that menu.

Wow, thanks :slight_smile: but I think that’s not the only reason, another possible reason is probably because one of my USB out-lets is busted (broken) which sometimes caused PC-BSD - along with some other gnu/linux distros - not to boot.

I will try your suggestion and get back to you, thanks for spending your time in helping me, and thanks for all the others who did the same.

video fail mode won’t boot :frowning: