How to auto start mpd at boot

I tried to create a symbolic link in config/settings/boot/launch but it didn’t work. I tried to start LaunchBox with the symbolic link it worked but not for mpd. How to auto start mpd at boot ?

What is the full path to the location you tried? It should be /boot/home/config/settings/boot/launch . There is also the file /boot/home/config/settings/boot/UserBootscript which can be used. It contains some commented help in it.

Here is a reference for the filesystem layout. Hope this helps:

The full path is
~> pwd
~> cd config/settings/boot/launch/
~> ln -s /boot/system/bin/mpd /boot/home/config/settings/boot/launch/mpd
ls -l config/settings/boot/launch/
total 2
lrwxrwxrwx 1 user root 20 nov. 16 13:10 mpd -> /boot/system/bin/mpd

for /boot/home/config/settings/boot/UserBootscript. I tried this line
/boot/system/bin/mpd &

mpd not start

Symlinking wont work as mpd wont be able to find its configs as the environment vars are not sourced in that case.
You should use the user bootscript and you should pass the config file to it, also use absolute paths like:

/bin/mpd /home/config/settings/mpd/whatever-the-config-file-called.conf &

But probably you dont want to use mpd on Haiku, because it freezes at music change. You are warned.

Use MediaPlayer, it is nice.

Hmm if MPD has a but maybe it should be reported. Granted I didn’t touch it for months but still… :stuck_out_tongue:

Also it should be possible to write a launch_daemon service file and set it to launch automatically.

A certain mp4 video file is opened by the media player, starts at the beginning and is already at the end. I hear a single word ‘ballaahh’ or something like that.
If I leave the window, ignore the error and start the mp4 video file again, it will play correctly.
This behavior is the same, regardless of whether the mp4 video file is started with a double click or via ‘Open file’.
All other players, including OpenShot, don’t have this problem.

Otherwise the media player works great. A MOV, created in 2003 using ArchiCAD on a Mac, is reproduced with excellent image and sound, it couldn’t be better!

Thanks, I can start mpd at boot now

Check attributes of that file, there’s one for position.
I’m pretty sure that’s there is already a bug report for that. I suggest that you dig for that bug on Haiku Bug tracker and vote for it.