How do you get files from Linux to Haiku?

I’ve done a bunch of searching about file systems, but I can’t find how to use some of my documents, graphics, and such that I have in an NTFS partition. I’d be happy to copy them to something else if I knew what would work.


Right click on the desktop and select img mount. Here select your ntfs partition.

Haiku can read / write ext2/ext3 also… but not ext4. Ext3 is probably the most stable intermediate filesystem.

There are ext2fsd drivers for windows that will let you use it there also.

I tried mounting the NTFS partition, and I got the message that it would be mounted read-only to prevent corruption… or something like that.

I put all my docs, pix, etc. on the big NTFS partition so I could access them from the Windows 10 system, which I haven’t run in ages since it started messing up my Linux booting.

All my Linux systems are ext4, but maybe I can find somewhere to set up as ext3.


Haiku can read and write to ext4, but be careful, Haiku can also damage ext4 (when Haiku goes to kdl, but that damage of ext4 is recoverable, at least it was for me), I sugest that you mount ext4 partition only in read only mode.
To NTFS Haiku writes very slow.
Linux can read BFS.

Ok, sounds strange, but i use OwnCloud :wink: Works perfect, since VirtualBox works not between guest and host.

Gparted didn’t recognize Haiku’s BFS, so I assumed Linux wouldn’t either. I’m in Haiku right now, but I’ll check when I’m back in Linux.

So NTFS is OK, huh? I think I’ll play it safe for now and use the little ext3 parition I just created from some unallocated space.


My test system is a hackintosh (based on Intel’s DH67GD mobo) and I have it set up to boot either Windows , Ubuntu 16.04, Haiku or Mac OS Mountain Lion. I can mount and read all the partitions from Linux, including BFS but, can’t write to HFS (Mac OS). I can’t remember if I’ve tried writing to the BFS partitions from Linux. I can write to NTFS partitions from Linux. Haiku can read my Linux (ext3) partitions and NTFS partitions but not HFS and I choose to mount the ones I can, read only. In terms of accessing files from other filesystems, in my experience, Ubuntu 16.04 rocks!

At least Ubuntu had BFS support (only reading, if I remember correctly). Not sure other distros. Maybe it had to be activated. Here is more info:

1 Like

You’ll probably need to install BeFS support from whatever Linux distro repository you’re using. It might not be in the default repository, though, so it may take some searching around.

The befs driver in Linux is read-only; if you want read/write BFS support, you’ll need to use our bfs_fuse driver.


can I get the bfs_fuse driver on fedora?

You should be able to get it on any Linux with FUSE support, you just need to build it yourself.

I have searched the Internet, Github, and sourceforge for the source,
Where can I find the source code?
UPDATE: I think I found the shell script here

I have bewen mounting NTFS partitions read-write for several years and never had a problem. The haiku devs are over cautious with the warning text on mounting non BFS partitions.

If you want to mount a BFS file system in Fedora Linux, use “dnf install kernel-modules-extra” and reboot. Then you can look into “Other Locations” in Nautilus and double click on the disk partition to mount it, though I think it’s limited to read-only.