How do i add fonts


#1

Before you ask,“yes”, i read this (https://www.haiku-os.org/docs/userguide/en/preferences/fonts.html).

But when i try to make a directory in ~/config,it says it is a read only file system

How can i add fonts,and how would i put them in a .hpkg. Im reading https://github.com/haiku/haiku/blob/master/docs/develop/packages/BuildingPackages.rst ,but it doesn’t really talk about how to put new items into the systems folders.

How do i get the fonts into ~/config/data/fonts/data/fonts so i can test them before packaging them into a .hpkg

I will be super thankful to anyone who can help me with this,as i intend to use haiku as my main os


#2

I FIGURED (part of ) IT OUT,put the fonts inti ~/config/non-pakcaged/data/fonts

Now,does anyone know how to put the fonts into a hpkg…I think i know how,but a little advice will help :smile:!!!


#3

Hello! There is an bash example to create an hpkg containing fonts:

Another one is using a little app mentioned in this post:

Good luck! :+1:


#4

Thank you,now the bash recipe to pakage fonts shows mw how to make a pakcage


#5

Or if you want to have a proper package just check the HaikuPorts wiki at github.


#6

Why you want to place fonts on a not standard folder? System folders are write protected, if you want to install something by hand, you need to place them in the home folder boot/home/config/…


#7

There are logical problems in your answer.
It is actually a standard font folder, except he had mistakenly duplicated the “/data/fonts” part.

And while it is a standard forlder, it is managed by the package_daemon, thus it is read-only.

One can put fonts manually either in ~/config/non-packaged/data/fonts OR in /system/non-packaged/data/fonts.

Or : it is really easy to generate a recipe for a package.


#8

That is a page that’s deprecated together with the Fonts preferences. Font settings were moved to the Appearance prefs. Not sure why that outdated page is still on the server. It’s not linked from anywhere inside the user guide (I hope…).
How did you find it? :slight_smile:


#9

You are right, i was in the false directory:

/boot/home/config/non-packaged/data/fonts