Hopeless hardware setup?

I’ve got a question I’m hoping someone can answer. I’m trying to install Haiku on a Dell Mini 10. It’s got a built-in Broadcom B43 wifi chipset, and I’ve also got an Atheros AR9271 external(USB dongle) wifi adapter. Now from reading documentation on the site is seems that both of these are a no-go since the B43 isn’t supported and USB wifi devices are also not supported. I just wanted to verify, before I give up my hopes, is it hopeless?

I’ve been dreaming of a BeOS/Haiku machine since 1998…and I’ve never been able to do it because I’ve always had some incompatible hardware (or back in the day I couldn’t afford the space for a separate partition for BeOS)

Are you sure the problem is not with the usb key or the way you formatted it? Also, where is the bug report with the crash logs?

I have a Dell Vostro V131 as my main machine currently, as far as I can tell everything except sound seems to be working. And I'll probably get to fixing the sound driver some day.

Dells are weird. I have a Latitude 2120 - a nice rugged little netbook. It will run Haiku all day, until I mount a partition or USB key formatted to Fat32. Then it crashes within minutes.

According to Trac https://dev.haiku-os.org/search?q=“Dell+Mini+10” this model is not very compatible. USB wifi is not supported in Haiku yet, sorry. Maybe it is possible to replace built-in wifi card?

Does it have to be WiFi? Is there an EtherNet port on that machine?

How about the rest of the booting, do you have sound and video ok?

Dell appears to be hopeless on a lot of counts. Some of their hardware is proprietary and requires proprietary drivers. I have a old VOSTRO-200 dual core. I don’t know what the issue really is but I built a USB Haiku boot/install thumbdrive and it locks up the system and does something with the power supply. I have to unplug external power and reset by holding the on/off switch. It may be a BIOS issue or power management but something just locks the system completely. My HP laptop with a similar processor boots just fine.
Older hardware should work fine. Just stay away from Dell.

@Ex-IBM: Truly sorry about your bad Dell experience(s), but your conclusion for all Dells is not quite true (“just stay away from Dell”). I tested two Vostro quad-core machines, and they booted and ran off the DVD fine; (granted, I had limited processor support on them for what they could do and tested 32-bit builds on x86-64, but they worked). I also tested a few Dimension machines in the past which worked (again, with optical media). The Latitude C/CPX and D series I’ve tested and found to work okay, with a few quirks (such as no sound). You might not get Wifi out of them (though the D420 does well with its Intel chip + installwififirmwares), but even in cases where it doesn’t, one could of course just connect to Ethernet or temporarily share Ethernet over Wifi with another (fully working) notebook as a workaround. The latter solution is a bit cumbersome, but allows you to be somewhat unwired. So, though I personally choose to own and work with Apple and HP products myself, I don’t think it’s fair to berate Dell to the point of telling others to “stay away” from their products and had to write something in their defense… poor creatures. I know – in most cases, they deserve it, but not all Dell spawn is junk. :slight_smile:

To the OP: If it’s just the wireless connection that isn’t working, and everything else IS working fine, I wouldn’t call that a “hopeless” setup. It sounds similar to an Acer Aspire AOA150 I tested. Also, have you tried the installwififirmwares script, or a Nightly? Some brcm (Broadcom) cards are supported; some aren’t, and you might just get lucky. I haven’t looked at your computer’s specs, but you might want to try this out. USB wifi is not supported, so forget that. But congrats on getting your little netbook going and good luck!

The FAT partition on the netbook itself was created with SystemrescueCD. Various USB keys were formatted under Linux, OSX and Windows. They all crash. But when I say crash, I mean total lockup, not a civilized app that crashes and brings up the debugger so you can generate a report. I mean a frozen screen, no mouse, no keyboard, no nothing. This happens reliably within 5 minutes of mounting the FAT partition. The same netbook will run all day if you stick with BFS. Yes, including BFS-formatted USB keys.

The Dell was upgraded to a 256GB flash drive, but this was happening when the old 384GB HD was still in it.

My mom-'n-pop-store desktop system will mount all those same USB keys without blinking. It’s the Dell, allright. I haven’t tried flashing the BIOS. This is not my main machine so perhaps it is worth the risk.

P.S. Running off a flash drive makes a noticeable improvement on the speed at which Haiku runs. Linux, not so much.

Okay… I’m probably overstating (an unneeded) concern then. :slight_smile: I’ve never owned or disassembled a Dell Mini (I did set up a batch with Ubuntu for a school once, though). My comment came from when I had two bad experiences trying to switch ipw to b43 cards on a D420 and a newer wl/brcm card in a HP Mini 110, and they both complained. Compatible cards worked fine on both in my case, though, and I haven’t encountered this elsewhere. Maybe it was a random fluke, I needed a BIOS update, who knows? So, maybe it was just me; I guess from that I assumed (bad, right there) that ALL those particular models were like that. My apologies if I went too far with my post; thanks for the correction as I learned from it. You’re most likely right and I’ll endeavor to be more cautious in the future!

Well, looks like pretty much everything works but I just so happen to have one of the two Broadcom cards (the 4312) that does not work with the FreeBSD drivers, ergh.

Oh well, maybe around the time BETA 4 comes out I’ll finally be able to run a BeOS/Haiku machine. The ethernet works fine…but it just seems kind of pointless if I can’t go to a coffee shop and use the wifi my machine has built into it.

I’ve waited a decade and a half I guess I can wait a little longer :confused:

The wireless card on the dell mini 10 is just a mini pci-e card. So you can get a different card on ebay very cheaply, then simply open it up and swap them over.

That works, but I’d be careful doing it… Some machines, like the early HP Mini and old Latitudes, did not like this and presented an error until the offending card was removed (in cases where it wasn’t compatible). So, I would definitely advise making sure the card is compatible with said machine before spending money and switching it out.

But just as an added suggestion, why not set up a bridge and use Wifi over shared Ethernet? A small, cheap Win8/10 tablet with USB Ethernet and an OTG adapter, or a small bridged netbook with anything *nix (like) or even Windows XP or > on it, would be a partial solution to regaining mobility for now. (And speaking of Unix, [Mac] OS X has done this from Jaguar, I think.) It’d be worth a try, too, if the OP wanted to…

Somehow posted double. Sorry…

I actually checked this before posting - I don’t own one of these machines. You can just swap the card, the BIOS doesn’t care what card you put in there.

Hey no problem, don’t beat yourself up about it! I have experienced exactly the same issue with numerous other laptops - Thinkpads are particularly bad. Often you can get around it by installing an unofficial patched BIOS. However in this case I think that the Dell Mini 10 isn’t one of the ones that complains. But I could be wrong of course, as I don’t own one!

do you looking for compatible notebooks, laptops? watch this german blog: : http://aspeers.blogspot.de

Any new Laptops tested? I would like to buy a new laptop for my daughter…
Just for fun I like to buy a Laptop which Haiku is running too…

Any idea? Should be a midrange Laptop…

Any help appericated…

[quote=brunobastardi]Any new Laptops tested? I would like to buy a new laptop for my daughter…
Just for fun I like to buy a Laptop which Haiku is running too…

Any idea? Should be a midrange Laptop…

Any help appericated…[/quote]

I just tried an acer aspire 5552 model pew76 with an AMD Phenom II and it screams with haiku, no hardware or driver issues to report yet.