HiQDock ... New Dock coming soon


#21

Can we get a x64 version too? I am on x64


#22

Is there a pre-release version that we can test now?


#23

The current version only works on R1A4 and requires Qt 4.8.5 (I have not released a binary or source code to the general public - please send me a private message with your email if you want a binary)… I have tested the binary on recent Nightlies and there are too many problems - it’s not even usable there.


Haiku has hope!
#24

Oh, I see. I don’t use Alpha 4 anymore. But after Beta 1 is out, if you want, I could be one of the testers for HiQDock. It looks really cool. It’d be really unfortunate if apps like this just disappear.


#25

Great news - with Heavenly Help I’ve fixed almost all the issues on recent nightly!!!

Stay tuned for release (looking for beta testers)


#26

just a caveat Haiku still doesn’t AFIAK support window transparency so there are still a lot ‘glitches’ so to speak (but it should look the same as the video I posted on R1A4)


#27

I want to test it


#28

Screen shot running on recently nightly using icons from Flat Mix icons


#29

Count me in. I will beta test the hell out of this delicious app in VM and on real hardware.


#30

How does it look with the Haiku zuMi (default) icons?


#31

You can put any icons you want, but they have to be .svg or .png format and of equal width and height.

You just have to convert the .hvif icons to .svg


#32

Sent you a little bugreport with screenshots, check your email.


#33

Me too on yesterday


#34

Thanks to lellodorin - he has prepared a working .hpkg for my HiQDock…

Hopefully, he’ll update here soon when it’s available on his repo (and I’ll need some help to get it on haikuports I guess).

… (FYI: because AFAIK, Haiku still doesn’t have true window transparency, the best mode to use my HiQDock in is the ‘auto hide’ mode)


#35

I have upload the HiQDock beta package on BeSly repo server:

http://software.besly.de


#36

When I try pkgman add-repo http://software.besly.de/repo64 it outputs
to stderr: *** failed! : Bad data
to stdout: Fetching repository info from http://software.besly.de/repo64 ...
Activating repository config from http://software.besly.de/repo64 ...
The repo is not added, exit code is 5

32 Bit worked fine.


#37

Our 64bit repo is not active, only for testing at the moment.


#38

:slightly_frowning_face:


#39

It would help if the 64-bit repo wouldn’t be mentioned in the instructions until it’s ready for action.


#40

HaikuDepot crashes sometimes just when I select an entry from Besly repo (32 bit) and non of this repo can be installed.