i didn’t come to troll- certainly not to knock haiku. i’ve actually used it before, and since i’m bored i’m probably going to try installing it on a usb key, through qemu. i have no idea if that will be usable after (even during) the first boot stage, but if it does that will be pretty cool.

i note that no one here likes gnu/linux- well, i didn’t like tomatoes for most of my life so far, and no amount of telling me i’d like them was going to change my opinion. i think they’re great now, but hey- if you don’t like it, you don’t like it. i kind of wish the hostility towards the os and kernel wasn’t based sometimes on information as old as 5 years… 5 years ago i had lots of trouble with it, too- but i appreciate the few people on the forums who have brought facts back into it.

so i hope that’s not trolling.

more like, i figured it was going to come up eventually, and i thought i’d just put it on the table. meanwhile if i can get python running in haiku, i might have some fun. i seem to remember doing something like that the last time i used haiku- not sure. like i was saying- hi. no, i don’t have anything against haiku… i’m not especially wild about proprietary drivers, but that’s hardly unique to your project. i’m trying to think of an os that supports zero proprietary drivers- can’t!

i’ll let you know how the installation goes- if the usb key idea doesn’t work, i might even reformat a real drive.

Welcome ou!

“i note that no one here likes gnu/linux”

That may just be a bit warped perception. There are a couple of threads in the off-topic forum where three guys argue in circles. The vast majority of Haiku users probably don’t care enough about Linux to waste time arguing about it on a Haiku forum. To me Linux distros are adequate tools to do some things I can’t yet do under Haiku, but it’s not fun.

Good luck installing Haiku under qemu. Though I recommend trying to install it natively on a partition - it’s so much faster.

Oh, and Haiku comes with a Python package and I don’t know what Haiku driver could be proprietary.


you addressed both the things i worded poorly- yes you’re right, i should have have said “almost no one,” i thought about changing it but it’s simple to clarify now. also i wasn’t implying that haiku HAD proprietary drivers, just that i presume it will support them. i don’t necessarily think that’s avoidable.

i think i got it to install from qemu, but i foolishly tried it on a usb key that already had grub pointing to the wrong partition. haiku’s really nice installer managed to repartition everything properly, i think, and install, but poor grub just couldn’t make heads or tails, and while i think i could fix that, i only know how from rescue mode after the fact of booting :slight_smile: so instead i just did it the way i should have and used anyboot.

the anyboot “install” (on usb) will let me boot (from usb) as many times as i want from qemu, using sdb as hda (it’s hda to qemu, anyway.) in short: it works fine from qemu, the anyboot image is fine.

if i try to boot on real hardware, it never gets there. it doesn’t even get to displaying messages, once boot starts it reboots, then tries to boot- reboot! tries to boot- and so on. i presume it’s a vesa incompatibility. how do i know? i don’t, really. but no installing on real hardware today. it’s pretty fast on that old machine running in qemu though. somehow i think i ran into this last time, i probably made a livecd but that was a good while ago.

Personally, I’d declare the day a vendor offers to provide an own, albeit binary, driver, a Haiku holiday! :slight_smile:

if i try to boot on real hardware, it never gets there. it doesn’t even get to displaying messages, once boot starts it reboots, then tries to boot- reboot! tries to boot- and so on. i presume it’s a vesa incompatibility.[/quote]

Hardware related issues are always very hard to diagnose, and I’m not very hardware-savvy…
The only advice I can give, is to check for suspicious settings in the BIOS (e.g. disable plug&play) and hold down SHIFT while booting and try out different boot options if your computer makes it this far.


there’s an interesting idea i wouldn’t have thought of trying, thanks. i’ll report back if it works. i haven’t given up yet, since qemu boots from my dd-written usb just fine, i’ve got my haiku usb ready for when i find a compatible machine.

i don’t think it’s making it that far, but i’ll try it, thanks. incidentally, i appreciate the tips (which i’ll try,) though i wasn’t requesting tech support per se. for that i’d use the appropriate forum- it’s kind of you to help, especially since you probably assumed i was asking (and not in the right forum, even.)

Hello, Nice to see you here. I do not perscribe to hating linux. I find linux users annoying and hateful however. It would be nice if they would just Go away if they don;t like Haiku instead sitting in the forums telling us how great linux is.

As to your boot problems.

Definately disable plug&play OS in the bios. for some reason this cuases aggrevation with a few different chipsets.

Try Safe mode with the Safe mode video mode. Pick a resoltion you know that your screen and your card or IGP support.

If you don’t mind, what type of hardware are you trying to run on. I’ve built up a pretty good mental database of what types and brands of hardware work and don’t work.

also make sure the IRQ assignments are unreserved. This can cuase problems with the IRQ routing setup tables and it usually ends in a interupt storm.

Anyways I’ll gladly give you a hand getting it up and running if the hardware will cooperate. to date I have only seen one motherboard that wouldn’t boot.