Help with getting Alpha 2 boot on VIA EPIA ME6000

I am trying to get Haiku R1 Alpha 2 (haiku-r1alpha2-iso) to boot a VIA EPIA ME6000 Mini-ITX board. I have tried booting from CD multiple times (regular, safemode, and safemode with everything disabled). It always crashes and enters KDL at the boot disk stage of the boot up.

Has anyone else has had luck with this board?

I have “Enable debug syslog” set but when I do a warm reboot after a crash I never get the option to “Save syslog from previous session”. Is there a way to save off the syslog to USB drive?

VIA EPIA ME6000 Mini-ITX Board Specs

CPU: 600MHz Eden Fanless
Chipset: VIA CLE266 NorthBridge
VIA VT8235M SouthBridge
VGA: Integrated VIA Unichrome
Onboard Lan: VIA VT6103
Onboard Audio: VIA VT1616 AC’97
OnBoard TV-Out: VIA VT1622
OnBoard IEEE1394: VIA VT6397S
Memory: Dimm DDR266 512MB

I only have a generic IDE CD-ROM drive connected when I boot. No other drives.


What does the crashes to KDL say?
No boot partitions found? Probably it can’t interact with the cdrom properly then, try booting from USB or preparing a disk where Haiku is already installed.

I have this board It works without any problems. Just as a reference. But I am booting from USB or from IDE CDROM. USB CDROM has problems in general from what I got from others

Most of the KDL error output appears to pertain the debugger handling and trace. The only thing that jumps out is “panic()…” followed by “vfs_mount_boot_file_system() …”

I’ll try a usb flash drive to boot. I appreciate the help.

Thanks ,

I have had the same mainboard.
It seems it is not completely VESA compatible.
Neither GRUB did work with graphical boot screen (text mode worked, and Linux booted normally to Desktop after that).