HELP WANTED: R1/beta2 boot & hardware testing!

By the way, in the Ouickguide not all Links working from 9 downwards. And a backlink to the top is missing in all chapters. in the Preferences menu Keymap-Switcher is half translated. in german Keymap-Wechsler

Jaaaaa. Coool. Just booted Haiku on my Ryzen based system. Works. I am here with WebPositive. Also YT plays my favorite songs.
I had to disable your Radeon Driver though.

So nice!!!

Thanks for the mention of the hardware list! :smiley: I really hope that it does help and I’ve tested a few Macs with the builds in the top post, which I’ll be posting soon :slight_smile:

Left my results on my NUC. :stuck_out_tongue:

1 Like

I tested on my System76 Oryx Pro, and all was fine except audio. I reported my findings in the survey. But when I looked at the Devices app, I got a kernel panic and reported it as ticket #16038 with a screenshot. I couldn’t find any other bug mentioning kernel panic and DevicesView so I figured it wasn’t yet reported.

I tried my 2011 MacBook Air and 2018 MacBook Pro, neither would boot the disc. However, I used to have Haiku on the Air and all worked except Wi-Fi, as expected. I reported these findings too. I like how the Haiku icon shows up in the boot menu though!


Checked 2 HP Pavilion laptops:
1 AMD based, need to blacklist radeon driver, no sound (HDA), wifi works
2 Intel based, radeon driver is ok there, no sound (HDA), no wifi (BCM4313 802.11bgn)

Good news for again test haiku :wink: openbsd has in near future release 6.7 too.

I want ask, that you make something like hardware release notes with supported hardware

Also worth noting, which I didn’t notice before, is that the R1B2 doesn’t show my laptop’s battery status, but hrev54010 does.

Now that is interesting. Please do open a ticket for that.

Created #16044. I’m sure where to look to get debugging information, but will do so if guided.

1 Like

I’m also noticing that Beta 2 not shutting down is also likely a bug, but it does stop the various components. It’s been a few minutes, whereas hrev54010 is quick.

This is probably related to your battery status ticket, actually; as both are controlled by ACPI. Please comment that there.

To elaborate on my previous comment:
It’s fully compatible with this NUC other then WiFi.
I can’t get it installed to the SATA SSD to save my life though. It installs fine but it doesn’t add the UEFI bootloader. I even tried the method to manually install the bootloader by copying files but it still doesn’t boot. I’m probably just doing it wrong. It works fine off the USB.

Yes, you need to follow this guide:

I even tried the method to manually install the bootloader by copying files but it still doesn’t boot.

Yes I did. It still wouldn’t boot.

will try and passing it on to few hacker friends!

I don’t know if this will count or not, since I’m a few more versions ahead after having done an update on it earlier, but here’s my IBM ThinkPad T42, running the most recent version.

Sound, WiFi, USB, and video work without issue.



Is there a command in Haiku which could list all the recognised hardware (such as CPU/GPU) once you’ve booted the system?

listdev will list all recognized devices, but that won’t tell you if it’s actually supported. Similar to the Devices app.
The wiki on reporting bugs has some more info at the bottom under “Hardware issues”.

1 Like

oops, sorry I didn’t notice the devices app, it was pretty obvious. The app can’t tell if the device is supported, but I can do it myself. I’ve modified the form to give a more precise answer. Thanks.