HELP WANTED: Haiku R1/beta4 boot & hardware testing!

It’s not much use posting this info here. As the man said:

sorry, I read the initial post many days ago, and I forgot some details, my mind sometimes plays tricks on me :sweat_smile:

1 Like

Where are the test candidates?
The links does not work for me!

I haven’t had much luck trying to download it today, either. Finally have the download going just a couple minutes ago.

Seems like the IPFS download takes a long time to get started and there’s some variability in the transfer rate. Might be worth attempting to download it with a download tool/utility that can resume where it left off, if that works in this context.

I filled the form report, but also adding it here.

  • Wifi used to work better on Beta3, it now seems to take 10-15 retries before it connects to the network and sometimes it will disconnect by itself.
  • My touchpad is detected as a PS2 mouse, and thus no gesture works (making right clicks is very hard, requires clicking in a corner and scrolling is not supporter at all). This is same as it was in Beta3
  • Bluetooth freezes on the “Retrieving Names” phase. It detects fine my headpones, but when trying to find their name the whole bluetooth app freezes. Not sure how it worked in Beta3 as I never tried it before.

This discussion should be inserted here too, or merged.

why? This topic is about hardware testing beta4. Not about the general feedback the op of the linked thread provides

Ok you are right, but here are feedback too included :wink:

I submitted to the survey, but I’ll post here too.

The x86_gcc2 version is working great on a Supermicro X8DTL-3f board, dual Xeon L5640’s. The onboard ethernet works, and Nvidia GeForce 7300LE works natively. No onboard sound or WiFi to test. I did try an Asmedia ASM1083/CMI8738 pci-e sound card but that didn’t work. Also, a SYBA SD-CM-UAUD usb sound dongle which didn’t work.

The gccx86_64 version wasn’t tested.

Will be fine to add your infos to our hardware database, but there a some infos missing, like your hrev you are running.

The RCb1rc0 build I used was hrev56578+62, kernel Dec. 18 2022. I forgot to add before, the X8DTL-3f motherboard’s onboard Matrox G200eW graphics worked but only in VESA mode. I’ll update the survey to reflect that.

1 Like

Hmm do you have the matrox IDs for me? I worked on that driver. Currently only analog VGA is supported on that driver though.


Hi rudolfc,

Here’s a screenshot of it in Devices:

just an FYI, if you have a windows 7 32-bit machine, Balena Etcher does not work. Use Win32diskimager. We might want to mention that on the install guide or download.

1 Like

I wanted to help here test on my hardware, but I could not find any downloadable ISO. The links in the original post don’t work. Are there alternative download locations?

These were pre-versions to test boot process. There are now release candidates available in this thread. Scroll down to last post if you want the “new” one (RC1).

1 Like

For what it’s worth, ImageUSB (by Passmark Software) should also do the job.

Hello. I tried beta3 and beta4. Beta3 works on my laptop [Asus A9RP/A9000RP], managed to boot to a working desktop with VESA. Beta4 doesn’t work at all. It either gets stuck at the black debug screen (enabled debug output to screen, otherwise it will hang) or KDL. Using safe mode & VESA brings me to a desktop but the Tracker quits and everything hangs. I filled up the survey form already. Currently looking for a long term stable operating system to use on this laptop since there’s no support from from hardware and software manufacturers even when the laptop is still usable.

1 Like

It is too late for the survey form since the release is already shipped. For remaining problems, please submit tickets at

Thank you. I’ll visit that link.