Help installing Haiku under VMware

Hi Everybody!

I’m having a bad moment trying to install Haiku under VMware. I follow directions in but when start the virtual machine I get an error message:

Cannot check for the existence of an old redo log for disk “d:\VM\Haiku\haiku.vmdk”. Failed to configure disk ide0:0. The virtual machine cannot be powered with an unconfigured virtual disk.

I have tried both in Windows and Linux as well as vmware version 1 and 2. I’ve also tried to rename haiku-alpha.vmdk to haiku.vmdk but no success.
Sure I’m doing something wrong but don’t know what. Any tip would be appreciated.

Thank you very much for your help in advance.


Hi Tolingo. Still got that problem?
I switched to VirtualBox meanwhile, but didn’t encounter the problem earlier with vmplayer. Mabe your haiku.vmx file is faulty. This was part of my .vmx:

ide0:0.present = "TRUE"
ide0:0.fileName = "haiku.vmdk"
ide0:0.deviceType = "disk"
ide0:0.mode = "persistent"
ide0:0.redo = ""
ide0:0.writeThrough = "FALSE"
ide0:0.startConnected = “FALSE”

Maybe check the “redo” line?

Hi Tolingo

You can't change the name of a Vmware disk because the file contains its original name and Vmware checks that the disk's file name is the same than the original name.

however, you can edit the configuration file (Haiku.vmx) to point to the good file (a bug has already be opened in trac )

ide0:0.fileName = "haiku-alpha.vmdk"

PS : If you play with Haiku in vmware, you may have a look at that :

Thank you both for your answer. As you pointed modify the line:

ide0:0.fileName = “haiku.vmdk”


ide0:0.fileName = “haiku-alpha.vmdk”

did the trick. Now I’m very happy trying Haiku.

Stars Seed your link seems broken but I think you tried to point me to

that it is really helpfull. Thank you very much


Yes I was referencing

I wanted to give you the link to the downloadable installation file, but the URL seems to be a versatile one !