Help - Haiku CD won't boot, xw9400

I recently bought (another) xw9400, with twin opteron 2435’s. I am trying to boot it from the Haiku installation cd alpha1R4. It gets part way through the boot sequence, then stalls at the icon of a computer chip. If I try booting in debug mode, the last lines of the log describe a PCI/PCI-X Bridge, made by NEC. There are several entries for NEC PCI bridges. Then it freezes. I also tried booting with nightly image 46922. I tried booting in safe mode, and checked many of the options – no difference. Any suggestions would be appreciated.

I have a HP xw9400 on which I installed Haiku some months ago. Tomorrow, I’ll try the latest nightly and see if it installs, and what steps are needed. One item you can check right now is whether you’re using SATA or SAS. Haiku does not support SAS. So, you must use the SATA channels only.

47867 ?

Tried installing Haiku again today.
First you must use SATA drives. Check to make sure you are using the right channels.
All attempts at booting Haiku alpha4.1 or any of the nightly builds from a CDROM ISO image will KDL. Therefore, you must use the anyboot image and install from a USB drive.
Both the x86_64 and x86_gcc2 builds installed successfully.

Thanks for the suggestions. I upgraded the bios to the newest version. The disks are sata, there are 3 sata controllers. hrev 47868 won’t boot either. iso cd’s have always worked for me. However I tried anyboot on a usb stick, and got the message “no operating system found”. Evidently I did something wrong. The usb stick was formatted fat32, with a bootable partition. I also tried it formatted BEfs, and nothing happened at all. The last messages that appeared on the debug screen were

“adding packages from boot/system/packages/”
“failed to open packages activation file : no such file or directory”
“loading packages from activation file failed.”

Then it goes into an infinite loop “timeout waiting for lost interrupt”, over and over again.

If you’re trying to install from a CD, try different boot images (ISO and Anyboot). On my PC, the ISO image KDL’s every time when using a CD to boot. I did not try burning the Anyboot image to a CD to see if that would make a difference.
I know the Anyboot works when using a USB drive. Read the instructions on creating a USB boot drive carefully. Are you using Windows to write the image files?

Thanks for the info. Well, I now know how to make a bootable usb stick from haiku. The anyboot images work, and I can boot the machine. But it doesn’t see any hard disks (there are two), and DriveSetup can’t find them. My guess is the bios is the problem. The bios screen says
LSI Corporation SAS BIOS. Even though there are 3 sata controllers, it appears that sas overrides them.

Go into your BIOS (F10) at the blue screen.
Check: Storage–>Storage Options–>SATA Controler #0, 1, 2 -->Enable
I/O–>Device Options–>SATA RAID–>Disable

Make sure you’re using the right SATA connectors on your motherboard. They are labelled SATA 0, 1, 2, 3, 4, 5 (second row of connectors from the bottom).
The bottom row are SAS/SATA 0, 1, 2, 3, 4, 5, 6, 7 - these are the wrong ones to use.

I tried CD installation using both anyboot and CD image files. For whatever reason it KDL’s every time.
However, installing from a USB drive works without issues.

Solved !!! Thanks so much. The disk connectors were plugged into the bottom row of sata connectors. I moved them to the upper row, and it now works. 64-bit Haiku is now installed on one partition.

I went through this same exercise a few months ago when I bought my xw9400. Glad I caould help you get Haiku installed. Now you can start submitting bug reports. It would be nice if you could try to reproduce the ones I submitted on my PC, so the developers don’t think the problems are all in my imagination. :slight_smile:

hrev 47885 anyboot went into KDL on my xw9400. But 48760 works fine. BTW, this xw9400 has 12 cores ! and they all show up on Pulse. I bought it on ebay from digitalmind2000. Thanks again !