I have downloaded and treid 9 different apps from haikuware. All of them were specifly for Haiku. Not a single one works… missing lib, unresolved link… it reminds me of Linux Lib Hell. Are there any apps on Haikuware that actually can be installed and used??

sorry about the rant… got a little frustrated.

Haiku has become a little less backwards compatible in the last months due to upgrading libraries to newer versions. Karl (from Haikuware) has brought it up [1] on the Haiku mailinglist, they are discussing it and I think it will lead to a solution.

I think this is happening mostly because Haiku is still alpha, but it is quite stable, so expectations are high. :wink: I do agree that at least most of the applications should work out of the box, but providing libraries with the system or application is a complicated discussion. A package manager would also help, there are ideas from Haiku, but it requires more discussion and implementation.

[1] http://www.freelists.org/post/haiku-development/Optional-Library-Package

Well he or she said these were specifically for Haiku, so does backwards compatibility come into play?

I am referring to applications that are “Haiku” and not old BeOS apps. But Haiku is alpha, we don’t have installer/package manager or equivalent yet. Maybe for beta 3. I just thought I could get something, anything to install. But, alas, nothing. :frowning:

There are hundreds off apps that work on Haiku at Haikuware. You tried 9/2650 apps or 0.003% on an Alpha 2 Operating System and then berate it and Haikuware.

This is one of my fav new Haiku native games that works fine:


Confirmed apps that work:


Try installing this first: http://www.haikuware.com/directory/view-details/system-files/shared-libraries/haikuports

and perhaps this for legacy apps: http://www.haikuware.com/directory/view-details/development/class-libraries/libpak

You should then see many of your dependency problems disappear.

Cool it Karl! I didn’t see him berate anything or anybody. He just chose some apps he was intersted in and tried them and they didn’t work, that’s all. Nice that you have pointed out the likely solution to his issues OTOH.


I just wanted to say that I did download the dependency zip file. Just for the record.

per instructions I put in /boot
un 7zip to zip and extracted to /boot
then KDL

Anyway, it’s ok. We are only on the 2nd alpha build and I am sure a more unified method will emerge for installing 3rd party software.

Everyone wants to be able to install Haiku then download cool apps and games and have some fun. There are thousands of old BeOS apps for download on Haikuware but as is pointed out, many have have some problems. We are creating a list of RECOMMENDED applications to run. These will be cool and reliable and provide you with big Haiku fun!

Please nominate your favorite BeOS/Zeta/Haiku applications here on haikuware for our growing list:

When Karl isn’t ranting at users he is working very hard supporting the applications archive at haikuware :slight_smile:


like Karl said, Haiku seems to be getting less compatible with BeOS.

It seems that fewer BeOS programs are now working with Haiku. People will have to start testing applications to see what and what does not work with Haiku and report it on Haikuware.

Bright side, there still is enough software for Haiku to keep me happy!

As Pieter pointed out up top there is a discussion on the development mailing list surrounding this issue so the developers are aware of it and wil be looking at solutions (we hope). Some changes were made fairly close to the time it was decided to release alpha 2 that IMHO are part of the cause of this fuss. For certain libcrypto and libssl wer upgraded from v0.9.8 to v1.0.0 which caused gnash and WebPositive to complain that the libraries were missing. Humdinger pointed out that I could simply create a link to the new library that has the name of the old one. This worked for WebPositive but, something’s still wrong with gnash.

Am I right in saying that some(most?) applications will need to be re-compiled against the upgraded libraries in alpha 2 and in some cases tweaked a bit, before they’ll work smoothly? Is there a way to compile applications to work with any version of a libreary newer than the one it is compiled against? Personally, I would prefer taking the risk that a new version of a library will break something in an app, than to have the app fail because a library it uses has been upgraded.

I dunno, I just think that unless there’s a significant change in a library an application shouldn’t complain about changes in minor version numbers. To be fair, going from 0.9.8 to 1.0.0 is not a change in a minor version number but still, WebPositve is perfectly happy using the new libraries so, why was it an issue anyway? How does software that “requires version x or newer” of a specfic OS or component/library work? I know that’s how a lot of windows software works and I’m sure I’ve seem linux software that works that way too but, again to be fair, VirtualBox requires that you download a specific package for each version of Ubuntu out there!

Pardon my ignorance but, following a brief search, I haven’t been able to find anything that answers all my questions. Not being a C++ programmer doesn’t help either, my main programming experience being some (self taught) VB/VBA programming where I did experince some activex and dll hell.

All in all, this is what alpha and beta testing is all about, catching problems like these and hopefully coming up with elegant solutions before the final release of r1.

I guess that this is what we get for living on the bleeding edge!