Haikuports - Help with my first recipe

Hello guys. After a lot of time, I decided to learn how to make a .recipe file. I’m trying with a very simple app made in Qt, that compiles in Haiku without any change to the default sources.

However, I’m having some issues related to the .recipe file. When running it with the haikuporter command, It get stuck at the following message:

waiting for build package qview_x86-2.0-1 to be activated
waiting for build package qview_x86-2.0-1 to be activated
waiting for build package qview_x86-2.0-1 to be activated
waiting for build package qview_x86-2.0-1 to be activated

My recipe file is this:

Any suggestions? Thank you for your help !!!

1 Like

seem you need to restart package daemon

A couple things you need to look at in your receipe that will prevent qView from building. First, rename your receipe to qview-2.0, not qview-20. You will need to check your architecture, I built my build on x86_64, which wasn’t listed and you have !x86_gcc2 listed also.

check your BUILD_ REQUIRES as you have some libs that are not required, along with adding to your BUILD_ PREQUIRES, the cmd for make.

In the BUILD portion of your receipe you will need to add qmake qView.pro, and finally you will have to work on getting it to install in the app directory. Currently it’s not installing in the app directory. The executable in the build is looking to be installed in /usr/bin

Have Fun!

1 Like

Hello! Thanks for your answer. I tried several times, after rebooting Haiku, but with the same result.

You probably have a mismatch between the recipe name and the PROVIDES entry or something like that. Then the package is activated under a different name and haikuporter does not find it and waits forever.

1 Like

Also, make sure the folder that your recipe lives in is named like the recipe, for example: apps-misc/qview/qview-2.0.recipe

1 Like

Well, thanks for all of your suggestions. I want to make some checks before continue:

The recipe name is: qview-2.0.recipe

The folder path is:

and I’m running the haikuporter tool with the following sintax:
haikuporter -S qview_x86-2.0

The PROVIDES section of the recipe is:

qview$secondaryArchSuffix = $portVersion

Can confirm if this is correct?

Instead of opening a topic here you should have open a pull request at haikuports, so we can:

  1. see
  2. test
  3. comment your recipe.
    Please open a pr, even if your recipe incomplete, broken etc.

what’s wrong with posting this in the official forum?

here people can learn something through it.

not everyone is looking for standardized information on haiku ports

It’s a lot easier to work from a pull request to debug things. Here we can talk about the recipe for weeks and still have no answer. With a pull request, people can try it and give more useful feedback.

Thats right but there is the first place people come?

We should have a instruction part on the top position of the forum there descriptions are (closed, no comments). Descriptions like there to post a bug report

1 Like

We do not epect perfect recipes when somebody opens a new pr, but it would be great if one would use the most efficient way to show the problem, eg. posting the actual recipe, and if somebody posts it, then why here, why not directly at github?
Please do not expect us to burn our time to find out the problem like a paraphenomen, help us to be able to help!
We should never talk about recipes here imho.

The “-2.0” is optional. Without it, the newest version is built. Otherwise it looks good. Time for a PR. :slight_smile:

1 Like

Hello. The PR was already sent. Thanks!

And commented on, only a few minor things and it can be merged :slight_smile:

1 Like

To be honest? I sometimes check in here to see what’s been posted, I see when PR’s (and not only me) are created at haikuports, it’s a lot easier to reply there and try to give instructions on what needs to be changed (or suggestions on how it could be done better).
We can react here (and when it comes to recipes I’ll try to look for questions here also), but trying to give straight and meaningful answers isn’t easy if you can’t see the source for the recipe)

I want to thank @Begasus and @humdinger for the help and suggestions done. I just need to deep into the .rdef files to learn how to add the extended attributes. Hope I will update this soon.


Try to take care of the outstanding comments before your hit that one :slight_smile:
If you are ready for that we’ll try to help anywhere we can :slight_smile: