HaikuDepot wont create account

Hello trying to setup the HaikuDepot software app and i keep getting "It was not possible to contact the web service"
i have a INTERNET connection and have run successfully run SoftwareUpdater. Also according to the website there is a code you enter before when you click create account. (No question appears like it does on the website graphic)

You shouldn’t have to really setup anything and HaikuDepot should just work. Can you perform a simple search with pkgman via the Terminal to test that you have access to the repos?

1 Like

I found out I couldn’t see anything in HaikuDepot until I did a full update. Once all the files were updated, HaikuDepot worked fine.

ok on the 32bit build haiku depot shows me packages on the 64bit version no packages.

do you used the correct repositories?

Hi just the default repository on both systems. on the 32bit system I just run haikudepot and get software on the 64 bit build no software is there

ok taken a look at the repositories that come as default on my 64bit haiku system and they are:

HaikuPorts https://eu.hpkg.haiku-os.org/haikuports/master/repository/x86_64/current

Haiku https://packages.haiku-os.org/haiku/master/x86_64/current

i am going to add the 32bit ports and see if it finds them and will run them

ok so I have got the following optional repositories work:

clasqm’s repo http://clasquin-johnson.co.za/michel/repo


FatElk http://coquillemartialarts.com/fatelk/repo

KapiX’s Depot http://haiku.kacperkasper.pl/repo/x86_gcc2


BeSly Software Solutions http://software.besly.de/repo

OK under the 64 bit nightly build of haiku Walter revision hrev51856 x86_64 kernel march 17 2018 only the above 3rd party repositories work, both the default 64bit and 32bit repositories wont syc and so you can install a port. on the 32bit system all repositories both 3rd party and default work fine.

There is no support for running 32 bit binaries under the 64 bit release (yet).


The empty list under 64bit Haiku sounds similar to ticket #13940.

I tried to create a new account, but there appear to be no captchas being sent. I created ticket #148 at HDS.