Haiku x64 (latest nightly) does not boot after memory upgrade

Hi All,

I am experiencing a very unfortunate situation. I just upgraded the memory of my Thinkpad T450s from 4Gb to 12Gb. I actually added 8Gb to the only one available slot. 4Gb is the internal memory. This is official upgrade. The machine can reach 20Gb total memory by putting 16Gb in the external slot according to the specs.

BIOS sees the memory OK and I ran tests on it, all good.
But Haiku does not boot (no icon lit) unless I activate the 4Gib memory limit in boot manager! In that case it reports the following:
12006 Mib total, 9697 Mib inaccessible
So, it sees even less than 4Gb now.

Actually I decided to upgrade the memory because I tried to compile webkit and reached the memory limit. I was thinking of upgrading anyway but that gave the final push.
So, I feel very dissapointed right now.
I suppose this is a special situation because I know that Haiku sees much more memory normally.

Any idea or workaround?
Maybe trying EFI instead of BIOS boot (which I use now) ?
Any help will be greatly appreciated !

I would wonder if it is because of the BIOS. Could you test booting maybe Linux or Windows from a USB drive to see what happens and if they can boot and see the full RAM? Though I suspect they might be able to overcome whatever limitation from the BIOS which Haiku is unable to overcome. Or maybe the way the extra RAM is added needs special support from the OS which Haiku does not have.

It does seem odd that Haiku won’t even boot, rather than just ignore maybe the extra RAM it does not support.

I tried searching some online and did not see too much about this, except people who said the BIOS also did not see the extra RAM, which is not your problem.

I am not much help, maybe some other Haiku developers with more kernel experience will have ideas.

Could it be that the extra RAM is allocated to video in some way?

You can check that if that helps though I guess that in that case it shouldn’t boot at all.

@leavengood and @Starcrasher thank you both for the feedback. I didn’t have any time today to test more. I hope tomorrow. I will certainly boot linux from usb to verify that it does see all memory.
Also, video takes 512Mb RAM through a BIOS configuration. Haven’t changed that for long time.

Please use the bugtracker to report bugs. It is not possible to track these problems conveniently on the forum.
And, yes, this is obviously a bug.

Hi @PulkoMandy. You are right. I will create a ticket for it.

Ticket created (#16809).

I found some time to experiment more and luckily I found a work-around.

Seems like EFI boot (from USB stick) works and sees all memory. The strange thing is that when I tried to select boot partition from (USB) EFI boot loader options it displays as available ONLY the hard disk Haiku partition; nothing from USB stick itself. For that reason it boots directly (and only) the hard-disk partition. It’s not a problem in my case but I cannot understand why.

I have put all details on the ticket.

BTW, is it recommended to use something like GParted to resize my hard-disk Haiku partition (if supports BeFS) to make room for a FAT32 EFI partition?

Currently, BFS resizing is not available (not even in Haiku).

Thanks @PulkoMandy. I will plan to do a re-partitioning then.