Haiku won't boot after installing(solved)

It’s strange, after installing haiku successfully, I reboot it and I get "PXE-M0F: Exiting PXE rom"
I’ve installed it on my other laptop before and this never happened, is there anything wrong?
I installed windows 7 and it booted fine. And then I shrunk that partition and installed haiku.
After installation, it went straight to windows 7. I put the haiku cd back in and reinstalled haiku,
this time taking out windows 7 and using the whole drive. After installing and rebooting, I get
the PXE message. . . I’m confused :C
If it makes any different, I’m using a Lenovo netbook.

edit

I’m using the nightly iso, btw. Is it recommended over the stable?

Firstly:
PXE is a protocol that will enable you to boot from a network drive or server. It is obvious that you don’t want to do that, but that you want to boot to a partitioned volume.

essentially your computer trying to boot from a network location.

So: go into the BIOS and verify that the boot sequence has your HDD and CD drive before the PXE Boot.
Maybe worth doing a chkdsk to make sure that the disk isnt damaged (boot to windows 7 or chkdsk with a repair disk)

Hopefully, you’ve installed Haiku to the correct partitioned volume.

Also, if this isn’t helpful, just simply boot to BIOS (usually hold F2 @startup) and set BIOS settings to default. Just make sure the the boot order is CD > HDD > LAN/USB/etc… or just boot to HDD first!

When you install Haiku, your BIOS doesn’t find a valid bootable volume on your HDD and then fall back to the next bootable device, that is : the ethernet one.

This can be caused by a BFS volume not being flagged “ACTIVE” in the Intel partition table, an invalid MBR boot code, an UEFI bootable system…

1 ) check for your system to boot from the BIOS (disable the UEFI boot)
2 ) when you create your bootable BFS volume, ensure to check the “Active” checkmark

You’ll may have to reinstall a valid MBR boot code since Windows installs its own (specific):
http://starsseed.free.fr/fixmbr.zip

NB : the nigthly build is recommended until Alpha4 is released (11/12/2012), but the AnyBoot image is better than the ISO.

  1. It’s disabled
  2. I thought that would solve the problem but I reinstalled, marked it as active. . . when I boot up, I get a blinking underscore at the top left OTL

[quote=el.tigre.20]Firstly:

So: go into the BIOS and verify that the boot sequence has your HDD and CD drive before the PXE Boot.
Maybe worth doing a chkdsk to make sure that the disk isnt damaged (boot to windows 7 or chkdsk with a repair disk)

Hopefully, you’ve installed Haiku to the correct partitioned volume.

Also, if this isn’t helpful, just simply boot to BIOS (usually hold F2 @startup) and set BIOS settings to default. Just make sure the the boot order is CD > HDD > LAN/USB/etc… or just boot to HDD first![/quote]

I put the PXE thing all the way down. I don’t have a copy of a 32-bit windows 7 though. . . the windows 7 I referred to earlier was installed at a store, it was a starter that I promptly wiped. . .

I think I installed it right. . . it’s the ONLY volume since I used the whole hard disk.

I loaded the default settings, changed the boot order. No avail, still blinking cursor :(((

also, how to you reinstall the mbr code? I downloaded the zip file.

Did you initialized the whole disk as BFS? Try to create an Intel partition map first.
Somewhat similar https://dev.haiku-os.org/ticket/8343#comment:7

[quote=Diver]Did you initialized the whole disk as BFS? Try to create an Intel partition map first.
Somewhat similar https://dev.haiku-os.org/ticket/8343#comment:7[/quote]
I think Rayyu already has an intel partition map on his disk.

then, you get a little further !

may be I should add a little READ.ME file…

  1. Start HAIKU
  2. Expand FixMbr.zip
  3. open the folder where the script FixMBR.sh is located
  4. start a terminal from this folder (context menu)
  5. run
    ./FixMBR.sh /dev/disk/ata/0/master/raw
    adapt the device path to your actual HDD (DriveSetup display the drive's device path)

PS : you can also install the mbr.bin boot code provided in the FixMBR.zip archive from linux doing :

dd if=mbr.bin of=/dev/sda1 bs=440 count=1
(adapt the device path to your actual HDD)

[quote=starsseed][quote=Diver]Did you initialized the whole disk as BFS? Try to create an Intel partition map first.
Somewhat similar https://dev.haiku-os.org/ticket/8343#comment:7[/quote]
I think Rayyu already has an intel partition map on his disk.[/quote]

I am a her :slight_smile:

may be I should add a little READ.ME file…

  1. Start HAIKU
  2. Expand FixMbr.zip
  3. open the folder where the script FixMBR.sh is located
  4. start a terminal from this folder (context menu)
  5. run
    ./FixMBR.sh /dev/disk/ata/0/master/raw
    adapt the device path to your actual HDD (DriveSetup display the drive's device path)

PS : you can also install the mbr.bin boot code provided in the FixMBR.zip archive from linux doing :

dd if=mbr.bin of=/dev/sda1 bs=440 count=1
(adapt the device path to your actual HDD)[/quote]

Uh, I can’t start haiku at all. It’s installed, but when I boot up it’s nothing but a blinking cursor. Can’t access it at all :frowning:

I’m gonna keep trying, though. It looks amazing on the livecd >_<

UPDATE!

initializing the intel partition map doesn’t work either. . . still getting the blinking cursor. I don’t really understand what’s happening. . . I’ve been able to install this with no fiddling on my laptop, but my netbook is giving me hell. . . :frowning:

[quote=rayyu]Uh, I can’t start haiku at all. It’s installed, but when I boot up it’s nothing but a blinking cursor. Can’t access it at all :frowning:

I’m gonna keep trying, though. It looks amazing on the livecd >_<[/quote]
So, how can-you install Haiku ???

-Boot from your Haiku CD
-clic on “Desktop (Live-CD)” instead of "Run Installer"
you should be able to run the FixMBR.sh script.

Thank you for all the help! I was able to boot haiku alpha 3 at last! :smiley: This link—>https://dev.haiku-os.org/ticket/8343#comment:7 seemed to solve my problem, specifically
this set of instructions from one of the comments:

Select the drive. Partition->Initialize->Intel Partition Map (agree to all the warnings)
Select the empty space. Partition->Create. It should be BFS by default.
Select the partition. Partition->Initialize->Be File System.

(I’m only mentioning it here because in the linuxquestions forums they usually ask people to post how they solved their problem. . . personally I think it’s a good practice :))

Anyway, I’m downloading the latest nightly for wifi support. Can’t wait for alpha 4 though :slight_smile: Thanks again!

Hi guys!

I had this problem too. This helped me:

However, it looks ugly when I boot now - but at least it works.

Ideally I want the Haiku logo to be the only thing I see when I boot up, the boot menu is visible very shortly.

Most excited to get started with this now anyway! :slight_smile:

Try this, if your haiku is correct installed you can use free bcd bootloader

http://besly.de/index.php/de/system/systemstartup/haiku-im-windows-bootmenue-einfuegen

You can use the “writembr” command from Haiku to install the standard bootloader (without menu). For this to work the haiku system partition must be marked as “active” in the partition table (in drivesetup there is a checkboxfor this when you create it)