Haiku will not boot past splash screen


#1

Hello everyone!

I just discovered haiku today, and I was eager to start using, so I downloaded and burned to a disc, but it wouldn’t boot past the splash screen, every little icon gets lit up including the rocket, if that makes a difference.

I’m using a compaq persario CQ60-211DX notebook.

specs:

160 GB hdd 120 GB free
2.16 GHz Intel Celeron Processor 585
1.9 GB DDR2 Sd ram
Graphics Processor / Vendor Intel GMA 4500M
Total Available Graphics Memory 797 MB

ALSO: I tried holding down shift and booting with failsafe graphics, still the rocket icon.

Thanks for any help in advance, and keep up the good work! :smiley:


#2

Which Haiku revision did you download? R1Alpha2 or a nightly image from haiku-files.org?

Did you try booting with safe-mode, not just failsafe graphics? The issue may be related to something totally unrelated to graphics.
You could also try to enable displaying boot message on screen and see what’s the last message.
There is also a feature allowing to see at next warm reboot the previous boot log.

All these options are available from the boot loader menu (hold shift key to access it).

In all cases, please file a bug report on our Bug Tracker at http://dev.haiku-os.org.
The more details about the issue, the better.
But file the bug, please…


#3

Very likely graphics related issue. Haiku boots with VESA mode and at rocket ship changes over to native graphics driver if available. In this case, likely the intel_extreme driver.

Did you choose resolution too when selecting failsafe video mode? You have to do both of these because Haiku may try an unsupported video mode with VESA driver.

Another thing to try is disiabling DMA, ACPI. And trying full safemode option which disables lots of stuff.

Also, if your drive is SATA, it may cause an issue too.


#4

Ah yeah, I have a SATA drive, that’s probably what it is, when I booted with the non-graphical boot screen I saw a bunch of errors related to my hdd, I’ll post them later,

However, the last line before everything hung was-

error starting “/bin/sh” error=-1

Like I said, if you can’t tell anything from that, I’ll post the full code later.

I’ll try disabling DMA and ACPI. I’ve been doing full safe mode.

Thanks again guys!
DFTBA


#5

“Haiku will not boot past splash screen”-???

That still would be something…
But the fricken thing will not boot at all!!! I tried 4 different computers, and it simply will not boot! (R1alpha2)
The download and decompression and burning of ISO image all went very well, only to find that the thing simply will not boot! How can they release such a defective thing?! I am very, very angry! I am on a very limited download allocation (quota) from my ISP… and than I waste this quota on ISO’s that end up in the rubbish bin!!!

Generally, I am very interested in Haiku, because I used to be a BEOS fan.
It is now roughly ten years after the sad demise of BEOS, and Haiku still cannot make an installation/liveCD that works! Therefore, I am not very hopeful for the whole project.
Probably won’t try again before RC1

steph51


#6

As you know, Haiku is a community effort, so you could help by filing tickets for each computer that doesn’t boot. Maybe those tickets already exist (a search with the right keywords will tell you). Also, Haiku is at the moment very likely nearer to the next alpha than to the R1alpha2 you used. In between there are the so-called ‘nightlies’ that you can try. Recommended.


#7

Try “dont call BIOS” as well as VESA mode. You might have to change some settings in your laptops BIOS to get SATA to work. If theres a setting for “legacy drives” you might try that.


#8

Really? Didnt work the first time so you give up? I boot from a USB key and use it as my main platform, Sure it just dumped me in KDL a few minutes ago due to some cryptic message concerning libraries and Thunderbird, but I layed on the power button and rebooted and its working again. Its still more fun than the alternatives. I still use BeOS as well. BTW, I bet if you boughta Haiku cd it would work.


#9

@tacotime
yes, SATA could cause an issue depending which controller you have (ie: non-AHCI SATA).

you may have to boot and use Haiku from USB stick which is next best thing to hard drive install.

@steph51
I would not give up hope just yet because you can try safemode options and that may get you to boot it. Do you get to the last graphic in boot splash screen?

First should check the ISO and burned CD to make sure they are error free. An error prone burn can cause Haiku to freeze and not work.

  1. use zip’s test/verify to check integrity
  2. use a burning program that allows comparing ISO file (on drive) to burned CD to see if they match up

If NO errors with steps above:
use SPACEBAR (press it while booting) to enter safemode. From there you can try different settings to see if Haiku will boot for you.

I have seen where Haiku won’t work for people on 1 computer but will on another system of theirs. Very rare you get 2 or more computers not able to support Haiku. With 4 computers, either bad disc, burn or corrupt download come to mind unless they have same hardware that Haiku is failing on.

Since you have download cap, you should wait for RC before you try Haiku again.

In about 7 out of 10 cases on a non-booting system, a user can use safemode options or change a BIOS setting and have Haiku boot for them.


#10

Seven out of ten times, my Haiku alpha2 will fail to boot.
The bootsplash spreads out across the screen in a narrow. lined band and the system stops.
A reset or three is required, before it will fully load.
Probably the vesa driver not quite cutting it? .
I have a Radeon 9800 pro.
I can live with it, and am very pleased when it does load :slight_smile:
Does anyone have any ideas about this?


#11

alpha 2, or a nightly build? (because i noticed that after a certain revision, the net_server stop me from booting)

Hold down shift, and then you will get some options, choose the one which will print on the screen the continuation/documentation of booting. And there you can see where exactly it stops booting.

And apropo, it would be nice, it an extra option would be avaible, which can prevent the net_server to be started. That would be a nice enhancement which could make life easier.


#12

Have a look at ‘syslog’ for clues. There should be some info about what video driver is actually loading and what error messages it gives.


#13

Whoa!
There are live people out there! That was quick :slight_smile:
I will investigate…
What I was really saying was: I don’t mind at all.
That it works as well as it does is a major event.
Haiku definitely has a future.
That really, really pleases me.

An aside:
Is the wonderful chat thing in BeOS going to make a comeback?
I haven’t used it for so long that I forget what it ws called: beshare, perhaps.
That was really fun when it was well populated.


#14

Sorry to reboot an old thread but I am having this same problem with the Dell Latitude 2100, most likely due to broken video drivers, usually forcing me to go into VESA graphics mode which uses the wrong resolution of 1080x576 instead of the native 1080x600 resolution.


#15

Forum is not really a good place to report problems with drivers. You need to use Trac for that. Anyway, according to specs Dell Latitude 2100 has Intel GMA 950, Haiku supports it though intel_extreme driver
Checkout this list of known issues: https://dev.haiku-os.org/query?status=assigned&status=in-progress&status=new&status=reopened&component=Drivers%2FGraphics%2Fintel_extreme&order=priority