Haiku, R1/Beta3 - Test Candidate 1 availablilty

Tried the x86 version in VMware

The deskbar crashed on shut down two times but worked fine. On the first boot (before the background wallpaper showed up) I have enabled “show application expander,” that might be the reason.

Both VMware add-on packages do not work.

The open sound driver is working.

The mouse pointer behaved funny a few times at first, switching the mouse control to the host then back to haiku fixed it when it happened.

is there a way to change the repos to test it directly from repos?

Can’t boot it on my machine, but then haven’t been able to boot a nightly for a while either so not sure I want to interrupt the beta3 process with that!

hm. could you open a ticket with a few details? Still definitely interested in what could be going on here :slight_smile:

Does it include updated WebKit?

Not yet. The Webkit guys are still working through the updated recipe. Hopefully TC2 will have it.

I will once I’ve found some useful details (unless spec is enough for now) - I’ve not been able to get any useful output or find any combination of settings that makes a difference yet! Jessicah suggested some older builds prior to the UEFI refactor, will give those a spin and report back.

This is the reason. See Random Deskbar crashes · Issue #12 · HaikuArchives/VMwareAddons · GitHub for how to workaround these crashes.

1 Like

run fine on asus mini Desktop PC E410

Installed the TC from a usb stick with no issues, and it has been stable thus far. The only thing that I’ve seen of note was after installing, I ran software updater and it listed updates to 55181+16 which I ignored.

I ran software update this morning and there was nothing listed, so it appears it’s been corrected.

Minor UX suggestion.
May want to update the instructions at:

From the First boot
If I choose Install Haiku instead of Try out Haiku
there is no path back to the desktop to copy the UEFI files.
The Quit button is changed to Reboot.

Might be related to 17039

My laptop doesn’t boot correctly with this TC1:

It’s the first time I have this issue with a Haiku install on this laptop.

I have to go Select boot volume, select Latest state, Return to main menu, and then choose Continue booting.


hmm. i’ve seen this one before as well booting from EFI on non-x86 platforms.

I’m working though generating a new set of initial_packages for haikuporter to get the webkit2 port running, but will circle back to this one right after to try and identify the cause.

Were you booting as UEFI via the anyboot as a CD or a USB stick?

1 Like

I installed into the HDD via a USB stick.
No problem with boot on USB, but now I boot on the HDD and I have this issue.

GPT disk, a 500Mio EFI partition (FAT32) and about 950Gio Haiku partition (BeFS).

I copied the EFI folder from USB stick to the EFI partition.

1 Like

@JeremyF Thanks for the clarification. I’ll try and reproduce this.

1 Like

Steps to reproduce at:

Hope this helps

Can you please give https://haiku.nz/files/r1b3/haiku_loader.efi a try.

This is a WIP patch that may resolve this issue.


My desktop actually sees this issue as well.

I was able to reproduce this issue locally within QEMU with the efi bios after installing to disk.
This updated EFI loader does indeed solve the issue for me.

I’ve fast-tracked hrev55216 into master since we are getting close to R1/beta3 (few weeks) and want plenty of testing time in the nightlies.

We can weigh + discuss ideal EFI / bootloader designs later after R1/beta3 :slight_smile:


Thanks, it boots!

But… loading screen is broken:

1 Like