Haiku R1 Alpha3 - Bootloader fails

So I tried to dd the anyboot image over a partition, make it active and everything, boot fails.
It comes to the screen when it should boot “Starting up…” and pc hangs for a sec, then restarts without even show the haiku boot logo.

Then I tried to boot off my usb, did that dd if of… and tried the usb with qemu… it worked fine. After that I plugged it in the pc, reboot… same thing happened… “Starting up…” reboot.

I read somewhere around the haiku forums that other people got the same problem so one guy posted a modified mbr at the tracker, so i fired up bootice, made a backup, apply the new mbr… partition fails to boot and reboot again, usb fails to boot and hangs on “Starting up…” without rebooting the pc this time.

I have no cd, even no cd/dvd burner so the only option to install haiku is thru usb or to fire up ubuntu and use that dd installer from there. :slight_smile: Still when haiku fails to boot at my real machine and the usb works at the virtual machines then I think it is pointless to keep trying to boot it there.

Any suggestions about modified mbr, boot loader which actually will start haiku? :confused:

MB: SuperMicro P4SCT
HDDS: WD Cavier Black 500GB Sata 2x Works in sata enchanced mode.
Integrated Ati rage xl (turned off)
External AGP Video: GF MX440 128MB
P.S. I tried to unplug the drives and disable sata mode to see if that causing the problem, still not working.

Hold down the key while booting. Can you get the boot menu ? If you get it, you can try to change the boot parameters and/or get traces. ( http://www.haiku-os.org/docs/welcome/en/bugreports.html )
Else, do you get a small text message just before your system reboot?

NB : you shouldn’t dd the anyboot image onto a partition but onto a whole disk.

I can’t get to the boot menu, it reboots just right before the menu shows up.
That happens also with using the USB and that usb works in the virtual machines, also i have no problems with booting from usb, the bios allows that and so far works perfectly with other bootloaders there.

Same thing happens when i’m trying to boot just the floppy disk, to test if the boot process will start and the menu will appears, even there the boot process fails before the boot menu appears too.

I was able to make the partition active and bootable when used dd over partition, just to bootlader still fails to load and to continue the boot process. Probably some hardware incompatibility there.

Also I know that i can’t dd the image over a partition since partition has pbr and i should use bootman and other workarounds after that to make that partition installation to work… still the problem occurs everywhere, in any possible way for booting the os… so i should run a ticket probably. :slight_smile:

P.S. I doubt that something is written in the syslog, since that function need to be activated in the debug menu, which is accessible thru the boot menu, somehow i can’t reach that point to give some more information around the issue I have now.

The easiest way would be to buy CD and burn haiku to that and then boot and install from CD

and i had same problem with usb boot, haiku boots fine on my laptop but on my desktop pc it would go to reboot loop

(Blame Google Translate in my mistakes)

Possibly related tickets: