Haiku on USB

Hi I am trying to put Haiku on a USB.
I get an error saying no such file exist.
I am trying to put haiku-r1alpha4.1-anyboot.zip or haiku-r1alpha4.1-iso.zip on a USB flash drive.
I followed the instructions at Making a Haiku USB Stick, to no avail.

I have created OS USBs before with no problem using Unetbootin.

This is most depressing.

Can anyone tell me what is the best way to put Haiku on a USB so I can try this most excellent OS?

Thank you


Alpha4 is a few years old, try the nightlies https://download.haiku-os.org/

This guide worked for me: https://www.haiku-os.org/guides/installing/making_haiku_usb_stick

Most likely you are trying to install Haiku onto a partition (eg /dev/sdc5) rather than onto the raw drive itself (eg /dev/sdc). That will always fail to boot unless you know your way around something like grub.

What is the system from which you are trying to do this? If you are doing this from Windows try using Rufus: http://rufus.akeo.ie/.

And yes, do grab a nightly. The official version is ancient history.

Hello and thanks for the support.

Kim 1963
That link is for another OS, I have Ubuntu.
Maybe I can share that with my neighbor.

This is what I have been reading about the “nightlys”:
“The Haiku source is continually built by a dedicated machine. These “nightly images” are provided mainly for development and testing purposes. You can download and install these snapshots to check out the latest features and bugfixes, be aware though that they may be unstable at times.”

I am thinking I should get the November 2012 release and then update.(?)

Also “https://www.haiku-os.org/guides/installing/making_haiku_usb_stick” is where I have been going from and the result is I get “something” on the USB Flash but it does not seem to be an “image” and when I plug it into another machine it is merely ignored.

I have tried do the instructions as per the above link and also with Unetbootin.

I am on an older version of Ubuntu. I have put ISOs on CD and I have put ISOs on USB. I am still a beginner but when there are instructions I usually muddle my way through - not this time.

The USB Flash is formatted to FAT32 and located at /dev/sdb

What is WRONG with the Official Version? Is the security out of date?

What is “written directly” mean?
"universal anyboot - can be burned to compact discs, written directly to USB sticks, or used with QEMU."
Does it mean I can skip downloading to my computer and download to the USB flash drive?

Fresh start this a.m.
Go to terminal to follow instructions at “https://www.haiku-os.org/guides/installing/making_haiku_usb_stick

Here are the results with the USB Flash Mounted according to the “Disk Utility”:
me@ferg-VII-160:~$ umount /dev/sdb
umount: /dev/sdb is not mounted (according to mtab)

Here are the results with the USB Flash NOT Mounted according to the “Disk Utility”:
me@ferg-VII-160:~$ umount /dev/sdb
umount: /dev/sdb is not mounted (according to mtab)

me@ferg-VII-160:~$ dd if=path/to/haiku-anyboot.image of=/dev/sdb bs=1M
dd: opening `path/to/haiku-anyboot.image’: No such file or directory

dd if=path/to/haiku-r1alpha4.1-anyboot.image of=/dev/sdb bs=1M
dd: opening `path/to/haiku-r1alpha4.1-anyboot.image’: No such file or directory

I have downloaded "haiku-r1alpha4.1-anyboot.zip"
Do I “extract” it to the USB?
Do I “extract” it to a file?
Do I “extract” it AT ALL?

Image of haiku “extracted” to USB:
</home/ferg/Desktop haiku on USB Flash Drive with properties.png>

USB connected to another Ubuntu laptop;
reboot and click boot from USB Flash drive - results:

The cursor at the top of the left side of the screen rapidly blinks as the flash drive is slowly dimly flashing as though it is dieing.

Actually the above sentence describes me - I am all revved up to try this thing and the hope fades to a dim very dim despair and disappointment.

You have to replace the “path/to/haiku-r1alpha4.1-anyboot.image” with the actual path to the image.

Extract the zip to your harddisk, then dd the image onto the usb device.

Hope that helps,

Thanks humdinger,

I have the following in my Downloads: “haiku-r1alpha4-anyboot.image”.

I put the following into a terminal: “dd if=/home/ferg/Downloads/haiku-r1alpha4-anyboot.image=/dev/sdb bs=1M”.

The terminal answered with: “dd: opening `/home/ferg/Downloads/haiku-r1alpha4-anyboot.image=/dev/sdb’: No such file or directory”.

I did also try a few variations of my own imagination - to no avail.

You forgot the output-file parameter " of". The correct line would be:

dd if=/home/ferg/Downloads/haiku-r1alpha4-anyboot.image of=/dev/sdb bs=1M




I don’t know if I am no longer a moron or not, I don’t know if you are actually a genius or not BUT I do know that I am thankful and you are thoughtful.

Geeeeee thanks.

And now for some reason it looks just like the instructions said to do it all along. Go figure.

OK I am on the road to … haiku.

Thank you all.

I’m hardly a genius and I doubt you’re a moron. :slight_smile:
It’s just that unfamiliar procedures are easy to get wrong, esp. in the shell where every letter counts. Once you’ve succeeded, the text describing the operation becomes clear. Which is also a problem for the ones writing such guides: They’ve done it all dozens of times and overlook the parts that may confuse their readers later.
So, for one thing I’ll change path/to/haiku-anyboot.image to /the/path/to/your/unzipped/haiku-anyboot.image. That’ll makes it a bit more obvious.

If you have other suggestions - for that page or any other - feel free to voice them.
We have to be careful however: too much detail and “hand-holding” would bore the more advanced readers. We have to try keeping the balance between detailed and boring.

Welcome to Haiku! :slight_smile:


Packaging. Since the official version came out, the devs have created an ingenious packaging system. It’s not like Debian or OSX. I think ROX is probably the closest analogy. All new software will be coming through the packaging system. There is an official software repository and three or four not-so-official ones. If you want software for your Haiku system, you have to be on the packaging system.

Surfing the nightlies can be frustrating. In the last six months we’ve seen networking come and go, Java support come and go … Don’t just update blindly, burn the new nightly to a USB key and test the hell out of it before you commit it to your main setup. hrev49669 has been rock-solid for me. If you hang around the forums you quickly hear what’s going on with the nightlies.