Haiku on Asus eee pc 701 4G

Just installed the haiku r1 alpha 2 on a usb stick and booted my eee pc from this.
Must say it was a pleasant surprise to see how good haiku already works on this netbook:
sounds works, network works, after disabling wpa on my router wireless works.
(I tried aslo wifi thetering with joikuspot on my nokia, but that didn’t wotk suppose the wirelss in haiku doens’t support adhoc connection?)
Seems a very good alternative to use on this laptop, thanks for the nice work

I have also tried JoikuSpot, and it did not work for me either. I wrote about it in this forum. The reply was that Haiku does not support Ad-Hoc.

My Nokia running JoikuSpot does not support infrastructure mode.
Maybe other phones do, but not my Nokia.

I just tried this on an Eee 701 4G too. The anyboot image effortlessly booted from an SD card straight to a usable desktop (just dd’d over the image). Wifi automatically connected to my router. I think its the only non-encrypted one locally, but still surprised there is no way of selecting the network. Impressive - just like BeOS.

Sound is working. Though not via headphones. Did you manage to get sound working via headphones? I checked settings and found ‘Headphones’ muted and set to 0 volume - adjusting them made no difference though.

Great stuff - looking forward to trying alpha 3 - or R1!


Just tried the latest nightly build too. Wireless network selection, headphones work & fixed a few other bugs I saw + I’m sure lots I didn’t. Awesome work:)



I’ve managed to get Haiku to boot on my EeePC 701 4G by moving an Anyboot image to an SD Card then booting off the SD Card. I can’t seem to get Haiku to recognise the main 4Gb SSD disk in the EeePC. Is there a relatively simple way of moving the installation over to the 4G disk?

I couldn’t install it (or run it) from a CD-Rom disk as it keeps failing after the disk detection phase of startup, reporting an error to the effect of ‘No boot media present’. [That may not be the exact wording…]

If not, can I expand the Anyboot image on the SD Card to make more of it visible to Haiku? It seems to be reporting the size of the (2Gb) SD Card as 650Mb, which I presume is the size of the Anyboot image?

Does it means that after booting Haiku from the SD card, your SSD disk is not detected by Haiku, which block you installing Haiku on it? Do you check with DriveSetup app to see if you SSD disk is detected or not?

If your SSD disk is shown in DriveSetup, you will need to create a BFS volume on it. Check DriveSetup menus to do that. When a BFS volume will be available, then run Installer app, the source volume will be by default your (SD card) boot volume, just select your new BFS volume on SSD disk as target and click Begin button.
Shutdown. Remove SD card. Boot. Enjoy your new SSD-based Haiku system.

If the SSD disk is not detected, it’s a bug. Do you know how the SSD disk is internally connected in that netbook? Via SATA, IDE, USB or directly via mini-pci? Usually, it’s SATA.
Also, as it succeed to boot from the SD card, you can attach to this ticket your /var/log/syslog in which valuable information could help find why. Give a look at the Welcome link on the desktop, there is a page there giving hint on how to get helpful bug report that will help you.

You can also try to press the shift or space key while booting Haiku from SD card. That will bring the bootlader menu, in which you could enable/disable some features that could forbit your SSD being detected by Haiku.

Thanks for your suggestions.

When I booted the EeePC from a Haiku CD, it gave me the error about the boot media not being present, whether I burnt the Anyboot or ISO image to CD Rom. I then copied the Anyboot image to an SD card which booted, but wouldn’t install to the 4G solid state disk. I tried a few suggestions I found for expanding ISO images before copying them to an SD (or USB) disk, this expanded the image size, but once the image was copied to the SD card it was still only 650Mb.

In trying many things I used Ranish Partition Manager a few times and at one point I formated the EeePC disk using this. After rebooting Haiku with the intention of installing the Anyboot image to another SD card I noticed that the internal SSD Disk was available to install to. I installed Haiku to the SSD and it loads and boot wonderfully. I formatted the EeePC SSD disk as FAT16 in case anyone else is struggling with similar problems.

I have also managed to get the WiFi (WEP) to load automatically on start. I have not been able to install many (any!) applications, most seem to have error messages that don’t yet make sense! Mind you, I am a longtime Windows user with a few years of Mac experience, but little experience of any other operating systems and their protocols. Why then did I try Haiku? Well the Windows XP install on the EeePC failed about three times in one month and I was fed up of re-installing it along with all my programs. I always liked the demo install of BeOS that came with a computer magazine years ago and was ready to purchase a copy when BeOS halted work on the operating system. I bought copies of BeOSMax, but could never get it to load reliably on any of my hardware. Very pleased that Haiku does now run on more modern hardware, and looking forward to monitoring the progress of this promising OS. All I need now is an easy to use port of OpenOffice…