Haiku on Android

Hello folks.
Someone on Xda-developers managed to port bochs to the Android platform, and it can boot Haiku.

I have tested this on the only android device I have around the house , namely my old xperia x8. This is a first gen device with 160 ram and a 600 mhz arm v5 cpu. I get all the way to seeing the pointer on the screen and being able to move it but then it locks up my phone.
Anyone with a phone/tablet that has 1ghz or up cpu should run this pretty decently.

So I created a zip file with Alpha 3 and everything you need to get this running.

Just unzip it to the root of your sdcard. It should be something like /sdcard/SDL /sdcard/Bochs2_5_1.apk. Install the apk and run it. That should be it.
On my phone it takes around 10 minutes to see the mouse pointer , but then again any newer phone has several times the processing power of mine, not to mention more ram. So you probably should see the desktop in less then 5 minutes.

There is no need for root.
The screen works as a touch pad , volume buttons are left and right click.

This is something to try out just for the fun of it. Don’t expect much functionality.

I’d like to hear how it runs.

Here is the zip. http://dl.dropbox.com/u/6739631/haiku%20android.zip

Just tried it on 2 of my devices
Yarvik TAB410, android 2.2: no result, bochs won’t work
Point of View mobii 10.1 tegra2 Android 3.2.7: Bochs wont work.

it installs correctly but wont run, nothing to set up, it stays in the background running empty.


Tried it on my Archos A101. It has 256 RAM and a 10” screen. The problem is that Bochs installs fine but won’t run. I tap the icon and the screen goes black for a second then nothing.

In order to get this to work you either have to put the sdl folder in /sdcard on your android or change the path in bochsrc.txt to where the sdl folder is located. I too had the blank screen then back to home. This will fix it.

Tried it again. Modified the path to c.img in every way known to man. Still nothing.

I successfully booted Haiku in Bochs on Android. It is very slow (AboutSystem says that the CPU is a Pentium 0D at 0 MHZ), but is somewhat usable. The Hard disc image is just about full, according to the indicator by the disk icon.

Le Pan 2 tablet. Does boot to Haiku screen and stop. The microchip is grey. After 10 min, I rebooted.No change. Thanks. Maybe we can make it work.