Haiku on a Hard disk

Hi, I am using Zeta 1.5 and have just managed to load a Haiku.image onto a Hard drive. I say managed because I have tried following the Howto on Besly and think something was getting lost in the translation.
I copied it to a Beos 5 partition and then deleted the Beos 5.
I then rebooted and get the Black screen with Haiku in colour in the bottom right hand corner, followed by the Blue screen with a White hand
and then it locks up.
Can some kind person point me in the right direction.
I tried the Bootmanager but,to no avail.
If I can get it to boot I will write how I did it, it’s very simple.

The safe mode option in BeOS is actually called, “Enable console debugging”. I believe same name in Haiku.

Console debug shows what is going on during the boot. This way you may be able to figure out what is stopping you from running Haiku.

Since you can’t boot into Haiku, you’d have to take digital picture of console debug info on your monitor & upload it somewhere. Or write down the ( last 5 to 10 ) lines you believe are causing the issue and type them out. At least console debug will shed some light of where to look to fix the problem.

Your specs look good. One thing really sticks out is the Sata drive. Haiku’s Sata driver may be trying to recognize your Sata chipset & freezing the system. Try disabling the Sata in the BIOS and check if that works.

If you see the boot logo then you’re on the right track.

For me, I just create a primary partition. Use BeOS to format it BFS. Mount Haiku image ( in BeOS ) and copy the files over to the new partition. Then I use Grub boot loader to boot off of it.

Problem could be related to your hardware ( too new? ) or maybe where the partition is on the disk drive?

Try pushing [space bar] when booting and see if you can get into safe mode so you can try some options. Like console output which would provide some insight.

Thanks for the reply and tips. I tried the space bar and tried all the settings , same result,( the only difference was the size of the Haiku logo altered). If I run Beos five I have to use the space bar. Although it looks ok and runs quite good.
My machine is:
Athlon 3200+ 64 bit.
1 gig Ram.
Nvidia 32 meg(old)
250 gig WD Sata.
Sis chipset.

The hard drive containing the Haiku(previously BeOS 5) is an IDE.

How do I provide a console output?

I disconnected the Sata, same result.
I ran the Debug console, but found it impossible to read the last few lines because the screen rolls off as soon as I press the key to show the last page. The last line reads, “No hardware found”.

Sorry but that does not help.

You need to look for lines that have “failed, PANIC, error or fault.” These will give the clue where the boot is failing for you.

Like in the eeePC boot you can see failed two times & PANIC once:

Try taking photos with a digital camera. Mine has continuous shooting mode ( which I can enable ) and it takes picture after picture without stopping.

Something else you can try is to boot only with a very basic system. That means disconnecting or removing, SATA drive, Sound Card, Modem, Ethernet, other PCI cards. And in BIOS, disabling USB, COM & LPT ports, Sound, LAN, Firewire, SATA, etc., etc. If you can boot with a very minimum config then you may be able to figure out what is causing the freeze by re-enabling stuff. But it’s better if you can look through console debug info because that’ll help narrow it down easier.

First thing, I greatly appreciate your help, Thankyou.
Second, As stated previously the screen that you want me to read from is the last screen I see. It differs from the six or seven prior screens in as much as I don’t get to see it. To explain, when I tap any key to see the next(last) screen there appears a black blank like space about 20 lines deep that moves from the top down to the bottom so fast I cannot see anything.
I have tried pressing the pause/break key but to no affect.
Also if it were possible to snap a shot of the screen,i.e. the screen was static , my screen is White type on a Black background, therefore the Black would absorb any light the Camera would facilitate.
I am going to try your idea of a barebone setup.

I removed everything , no go. Same result.
I tried the Console whilst the Comp was bare and found one change, I couldn’t get the last page to appear (as previous). When I tapped the key for what should be for the last page to appear it went into the Blue screen with the White hand.
Me thinks we are flogging a dead horse , so to speak!

Maybe it doesn’t support your SiS chipset motherboard? Hopefully you are testing with a primary partition near the start of the drive. But if BeOS boots off that partition then Haiku should work off of it too.

If you have an older system handy, then try that drive on there & see if it’ll boot up. ( that’ll eliminate a partition/drive issue ).

Without console debug info it’s too hard to figure out what is causing the issue. ie: only can guess what might cause it.

Seems like you’ll have to settle for using the VMWare image for now and every 6 months you can try a newer Haiku revision to see if it works. Later.

It’s funny you mention another older system. I’m looking on Ebay for a Pent2/3 dual Processor board. I got one the other day but it was DOA.( Got my money back). I had an old Compaq server that died on me and was impressed with the speed of the dual Cpu.
Anyway , thanks for your help.

Hi, running a similar setup to you and had exactly the same problem either yesterday or the day before (can’t remember now :D)

Blue desktop, no tracker/icons, just the pointer, frozen in the middle of the screen.

Anyway, a couple of revisions later the problem just went away (for me at least).

Are you using the latest revision? If not, check out the latest rev if building yourself or, if not, you might want to try a more recent image.

If your system was incompatible for any reason I personally don’t think you’d even get as far as the desktop itself.

Hope this helps

edit: fix typo, and;
My Haiku install is also on an IDE drive, my other systems are on SATA so you should be ok!

Hi Thanks for the reply. I am using the latest version, so no luck there although I will just keep trying.

By the way I should still have a Supermicro P6DBE here somewhere. It’s been a couple of years since I used it but should still be ok as far as I know. Interested? I may well have a matched pair of 550 P3s to go with it too :o)

Al, thanks for the offer. Thats virtually the board that was DOA.
Supermicro +D6BS(I think)…
Question, where are you ? I’m in the UK.

Uk, Nth Yks :o)
I’ll try and get my email to you somehow, unless you frequent freenode #haiku?

Al, I haven’t been on Freenode, but give me a time and where to look for you and I’ll be there.

Al, Click on my name and then contact.( I have just altered my profile) Cheers,

Ships to Brasil these P3 at zero cost? ehaeuauheuahe