Haiku not utilizing all processors?


#1

Hi, I recently tried out the Haiku beta1 32bit in a VMWare VM, and had a question about the processor management.
It is my understanding that Haiku uses all available processors for all processes and after looking at the pulse CPU meter and running GLTeapot demo it seems that only 1 processor is being used and even after adding more teapots, all it did was max out the utilization of the 1 processor, and none of the others have any load on them. I tried enabling/disabling the other processors but the performance nor the utilization changed… is this a bug in the software or is there a setting I need to change?

Thanks!


#2

From what little I’ve heard about OpenGL, it uses a static context that is accessible only by one thread. That’s why PlayStation 3 development required OpenGL-ES 2 instead of OpenGL 3.x.


#3

The 32-bit OpenGL rasterizer is just Mesa 7.x’s stock one, and it uses only one thread. Not much we can do about that, it’s not a Haiku bug. (64-bit and GCC7 Mesa should use multiple threads already.)


#4

You can run multiple instances of the GLTeapot window (not multiple teapots in the same window) to enjoy 100% CPU use on all cores.