Haiku mostly working on Fujitsu u810 laptop

Not sure where to put this so it goes here.

Over the last several days I’ve been playing with many different operating systems on my little Fujitsu u810 laptop. Many don’t ever even finish installing. Haiku seems to mostly be working and is nice and fast.

Here is what is odd, described only so that support can be built into a future release.

  • Battery - does not seem to be supported at all.
  • Atheros 5006 abg wireless does not seem to work even with the 12/26/2009 nightly build but I have not tried to install it the “hard way” yet since I need to plug it into a wired port.
  • Audio mostly seems to work but it not what I would call normal. When headphones are plugged in the audio still comes out of the speaker, would be nice to change this.
  • Touchscreen - it sees part of it and when it is touched the point moves to the lower right corner of the screen. I assume this would be extremely low on the list.
  • Sees USB webcam, not sure if it works as I never got an image out of it. This is less than extremely low on my list of priorities I never want to use it.
  • Bluetooth doesn’t even seem to be within its realm of thought yet.
  • O2 flash reader does not function at all, this seems to be a problem with a lot of operating systems.

Over all I am impressed with how well it runs. I purchased the R5 professional version of Beos years ago and never did too much with it, nice to see that it pretty much continues.

Very interesting indeed. I bought a U810 about 3 months ago and love it. I’m currently running Ubuntu Karmic but I’m an avid stalker of the Haiku universe :slight_smile:

I’d be interested to keep in touch with you on your successes going forward. I think Haiku will probably the OS that breathes some serious life into my little toy.

For battery you probably just need to enable ACPI, it’s disabled by default atm.

Thanks I’ll look around and see if I can find out how to do this. Even if it doesn’t dim the screen it will at least tell me when it is time to plug the thing in for charging.

Hi Greg!
You can enable ACPI and toggle other options in the file ~/config/settings/kernel/drivers/kernel by uncommenting the respective line.


For those that are not up to speed…

Click on the Haiku icon on the desktop --> home --> config --> settings --> kernel --> drivers --> double click on the kernel file and edit the features.

I defeated multiple processors since this machine only has one. I enabled APM and ACPI, reboot. Left click on the leaf on the deskbar hover over desktop applets and choose power status which then pops up a window and asks you if you want it to live on the deskbar which I said yes. Gives the approximate time left on the battery and if you right click on the power meter some options like time or percentage and about the battery which is cool.

If I boot with the power plugged in, then I get I get full processor speed of 800Mhz, if I boot from battery I only get 600Mhz and the speed will not change if I plug the power in. Also when it is charging it doesn’t show a different picture but it does change the time to display the amount of time until full charge (I assume). I can also make it display 1.1Ghz which I do not believe is correct, but I’ll let it ride for a little while.

Tried changing the BIOS from Tablet to Touchpad to see if Haiku was able to tell the difference, but still no luck on the touchscreen.

Well little steps are good and it is getting more functional as time passes.