Haiku Live CD fails to post beyond initial post screen rev.43844 nightly

Hi there,

not sure if this the correct area to post this in & whether or not someone knows about this already, but recently the Haiku Live CD has stopped posting past the initial boot screen/freezes on all boot icons lighting up. This fault appears to have been introduced relatively recently. The last version of the nightlies that I managed to get to post had some garbled video-mode upon booting into Haiku Live CD (Radeon ATI HD5770). (438## ?)

I’ve tried the latest rev.43844 on both an X58 chipset motherboard/I920/ICH10R and a Hp8510W laptop/intel t7700/ICH8m/intel 965m express chipset, and the freezing occurs on both systems.

Please ignore this post if everybody already knows about this. I just thought everybody probably does their testing using VMs these days and maybe not the ISO live cds, so maybe the fault isn’t showing up in a virtual enviroment.


I experienced the same problem. The last nightly to boot was haiku-nightly-hrev43776-x86gcc2hybrid-cd. Every nightly after that one just hung at the boot screen.

I just tried every image from 43776 to 43867 as well … 43776 was the only one that was able to boot all others are doing as you describe. I run A3 quite nicely so nightly images aren’t really a big concern for me but I do like to test them out at times.

BTW: It should be noted that images I tried were standard ISO (which have been depreciated in favor of anyboot anyway). I tried the iso’s both in virtualbox and burned to cd on live hardware - the same machine I run A3 on - with the same result. I can’t seem to successfully burn the anyboot image for some reason so I can’t test that one (and I HATE qemu with the utmost of contempt). The vmdk images do boot fine for me.

Sounds like https://dev.haiku-os.org/ticket/8369 …and please use the bug tracker for bug reports, the developers in general don’t frequent the forums.

live cd works now again with 43877 thx…

but cannot install to hard drive… data error…

[quote=Bruno Brocoli]live cd works now again with 43877 thx…

but cannot install to hard drive… data error…[/quote]

Thanks for confirming that the ISO’s work again! But … these forums are not a bug tracker. Please, please, file tickets for these issues. One way to think about it, there’s only two types of bugs that get fixed – 1. ones that you fix yourself. 2. ones that the developers are aware of.