Haiku isn't booting (AMD)

I’m trying to boot Haiku, but can’t, none of icons not lightning on booting screen. I cannot debug this state, cause even enabling on-screen log from boot menu, it’s not appearing. USB keyboard (and all USB devices) not working after starting boot, but PS/2 keyboard is working, I can reboot PC with Ctrl-Alt-Del on it. I’ve tried safe mode, various modes in boot menu, tried boot from USB, CD, SATA and NVMe drives, legacy and UEFI boot, x86 and x86_64 latest nightly builds. How I can boot Haiku on my PC? :fearful:

CPU: AMD Ryzen 5 3600
GPU: AMD Radeon R9 270X
Motherboard: MSI B350 PC MATE
RAM: 16 GB

Welcome @SilverSword to our community

Have you more specifications about you hardware?

Some times modules are not supported and can stop running the system. You can blacklist them, but you need to know that hardware is blocking.


Please submit a bug report at https://dev.haiku-os.org/
You can check the boot loader log in the bootloader menu to see if something already went wrong there.


Most likely CSM (AMD) secure boot needs to be disabled. I’ve got similar specs (MSI x570, 3700x and 5600XT) and Haiku only boots with CSM disabled. The secure boot keys are a joke, Linux actually uses Microsoft Windows keys to trick the UEFI system that the boot manager is authorised (completely bypassing the point). But hey, government and corporate clients want Secure Boot, and Linux does what it can to boot (uses Windows keys). The other alternative OS’s are refusing to play this game, and good luck getting MSI in 2022 to include Haiku signatures in CSM keys. Maybe next year :slight_smile: .


Can’t we use the same trick as Linux?

I read some topics about disabling modules, I’ve tried turn off network drivers. Also, in UEFI settings I’ve tried turn off network and sound card, it’s not working too.
What more specifications are you want to see?
Network: Integrated Realtek RTL8111 Gigabit and PCI-E Wi-Fi Intel AC 7260, also I have an old PCI card Intel Pro 100B
Sound: Integrated Realtek ALC892
USB: AMD Promontory ASM2016C Chipset - xHCI
South Bridge is AMD K17.7

In log from boot menu I can see only initializing my drives, partitions and so on

Secure Boot is disabled, cause I’m also using Hackintosh. Also, I’ve tried disabling TPM, but it’s helpless too :fearful:

Please disable AMD ATI, and maybe Nvme. This script may a help you

Package haiku  {
	EntryBlacklist {

Please put this script to Haiku??sory, name of file is a packages

1 Like

I see that you have hardware who are almost supported, seen on our hardware database:

Realtek RTL8111 Gigabit = Ok
PCI-E Wi-Fi Intel AC 7260 = Ok
Integrated Realtek ALC892 = Ok
AMD Radeon R9 270X = Not listed
MSI B350 PC MATE = I does not hear about a board that is not supported (to the toady stand not reported).

So this should not make such trouble.

Have you connected any USB hardware beside keyboard and mouse? Have you tried to remove them all (only keyboard and mouse)?

You can blacklist the drivers for the radeon using the bootmenu (Space bar at booting).

1 Like

This can’t work as the kenel is not loaded yet.


With proper BIOS implementations it is possible to add or remove keys yourself (my laptop has these options for example). Wouldn’t it be nice if our bootloader was signed with our own key so we can use that?


IIRC @kallisti5 was already working on just that :slight_smile:


Of course, I’ve tried this too, but, as @Diver said, I can’t load kernel itself.

How can I get any debug information, when I turning on on-screen debug log, I can’t see any text? I don’t want open bug report without any useful technical information.

In my PC USB Microphone, Capture Card and Bluetooth from Wi-Fi PCI-E card are always connected. When I’ve tried using PS/2 port and keyboard, I’ve turned off all USB devices. Another thing that I’ve noticed - when I’m booting, USB keyboard is turning off any LED and backlight, mouse is losing connection with Logitech Unifying and trying to find it again (blinking LED).

It’s hopeful :blush:

1 Like

One part about opening bug reports is that devs can help you provide the info, it is better to open a bug otherwise the devs are unaware and it won’t be fixed.

You can provide the info you provided above, like used hardware, observed symptoms, etc. that is already usefull info.


CSM ?? my machine won’t boot either, will check, thanks !! Amd ryzen here as well

I created a dev ticket #17953 (Haiku isn't booting) – Haiku
Also, I successfully booted in Haiku with CSM boot and ticked “Ignore memory beyond 4 GiB” :blush: But loading from EFI is still don’t working.