Haiku in VMware Fusion questions


#1

Hello,

Context: My main computer is an iMac 27 with OS/X 10.9.5, RAM 32 Gb. SSD 2 Tb. and I use VMware Fusion 8.5.10 Pro for all my VMs (several different Linux distros as well as Windows 7 and 10).

Just discovered Haiku and installed Haiku in a VM from the haiku-r1beta1-x86_64-anyboot.iso file and was pleased to see how the install process is fast (Vs. the installation of any Linux distro or, worst, Windows 10).

After booting, I ran the Software Updater, updated the system and after a reboot successfully installed the VMware add-on tool.

1- Then, I could move the mouse in and out the VM (i.e. without being obliged to press Ctrl Cmd), but no way to perform any Cut and Past nor dragging files form/to the host.

2- For the same purpose of exchanging files from/to the host, I didn’t find a way to access to a declared (in the VM properties) shared folder of my iMac.

3- Further, I have no sound (message: could not find the mixer) and didn’t find the opensound driver in the HaikuDepot.

4- Last, I can’t see the Camera of the iMac in Haiku while declared in the VM properties.

So, I’ll appreciate your help to fix these four first glitches before to go further.

Thank you in advance.

Best regards.
Fnux


#2

No oss for 64 bit, technicallyno webcam support, no clipboard or file share support in vm.
Use ssh, ftp, or something else.


#3

Hi extrowerk,

Thank you for your response.

So, may I guess I’ve to wait several months (or years) to see an RTM working seamlessly in a VM (whatever VMware Workstaation, VMware Fusion, VirtualBox or Parallels)?

BTW, is there any equivalent tool of Filezilla available for Hiaku?

Thank you again.

Best regards.
Fnux


#4

Yep, ssh is always available.


#5

Who know? As soon as someone capable that needs that feature comes along and is motivated enough to fix the VMware add-on, the wait is over.

I don’t use a virtual machine, and when I have to use VirtualBox. So I don’t know exactly what’s working of the VMware add-on and what’s not. I guess you did try to mount the shared folder as described in the package, mount -t vmwfs -o Shared ~/Shared ?

You also mount a nfs4 network share to exchange files.

FtpPositive is a ftp client (no sftp though).


#6

Hi humdinger,

Thank you for your reply.

Unfortunately, I’m not scaled enough to contribute to the code.

I’ve to learn how to do both of that on Haiku. Any book for that?

BTW, Haiku being in its early development stage, I guess it’s a secure way to use it mainly on VMs (or dedicated bare metals if/when you’ve some). Then, I think the dev team should very closely looks at the different vm tools they provide.

Yes, I found it and installed it. But if it’s working as expected, how can such a small program be so slow?

Note: My dedicated Haiku VM has the following settings: 4 CPU cores, RAM 2 Gb. and HDD single file of 20 Gb. BTW, why the Virtual HDD is set as IDE and can’t be defined as SATA?

Best regards.
Fnux


#7

No book, but the Terminal is a bash shell, so most of what you find on that on the web is applicable.

After creating a folder “Shared” in our home folder, just enter into Terminal:
mount -t vmwfs -o Shared ~/Shared

As I said, I dn’t use VMware, so I don’t know how correct this line from the package description is…

I don’t think Haiku provides any VM tool. That VMaddon package is a third party effort.

Maybe something’s wrong with your VM settings, I don’t know.
Also, I bet I can make any app slow, no matter its size. :slight_smile:


#8

Hi again humdinger,

I’ll try that later when I’ll find the response of the question below:
e.g. if my OS/X shared folder is named “Common-place” and my Haiku shared folder is named “Downloads”, then what should be the right command line?

The vmware add on is in the HaikuDepot. So, that’s why I was guessing it was provided by the dev team.
Anyhow, since I bet most of new users will first make Haiku triees within a sand boxed VM for obvious security purposes, my view point is that for a rapid spread of Haitku, the dev team should seriously take a look at the different VM add-ons, whatever it’s for VMware Workstation, VMware Fusion, VirtualBox or Parallels. Just my two cents.

Nope! My VM settings are OK.( e.g. the Software Updater and the HaikuDepot are fast to download). So, it’s only about this specific piece of software that takes over 2 minutes to show the simple content of the root of my web site that has less than 7 folders. Same delay to jump into a folder that has less than 10 files, etc.

Whatever, this entire Haiku thing and its different apps are still in their early development stages and I don’t complain. Just pointing out some graceful remarks. :slightly_smiling_face:

Thank you again for your time and concerns. :hugs:

Best regards.
Fnux


#9

There aren’t many possibilities here, right? :slight_smile:
Should be mount -t vmwfs -o Common-place ~/Downloads.

No idea. It’s fast when listing folders or transferring files to my NAS…


#10

Thank you for the clear sample.

I didn’t try ftpPositive on localhost or on a LAN but connecting to my real external web server.

When using Filezilla whatever on my different Linux VMs or my Windows 10 Vm, the listing shows up within 2 seconds max (i.e. with the same VMware network interface performances).

When using ftpPositive on my Haiku VM, the listing appears after almost 2 minutes (i.e. still with the same VMware network interface performances).

Below is a screen capture:
ftpPositive

That’s so slow that the first times I tried this software, I was thinking it did not work and closed it after waiting 1 minute or so.

Then, later I did retry but I’d something else to do in one other VM and when I checked my Haiku VM back, I found the result. So I jumped into a folder and the long long long behavior was the same.

Meanwhile, the file transfer download was pretty fast.

So, that’s just a point to investigate, but not a big critic as long as this is still beta.

Thank you again for the command line sample.

Have a good day or night (it’s already 1 AM my time and I’ve to go to bed).

Talk to you soon for other inquiries on Haiku.

Best regards.
Fnux


#11

I’m using vmware workstation in Windows with the vmware add on for Haiku beta 64 bit. Sharing clipboard works fine, as does network connectivity.


#12

Сlipboard is supported btw.


#13

Hi adamfowleruk & Diver,

Thank you for your posts.

I don’t doubt it’s working with VMware Workstation Pro on Windows hosts, but I just and only said both the clipboard sharing and the copy/past as well as the drag & drop from/to the host don’t work from a Haiku VM with VMware Fusion Pro on an iMac with OS/X when the VMware addon is installed.

Further, in such a Fusion VM, there is no sound!

I only hope the dev team will take a close look at it, but for me it’s not a hurry as long as Haiku stays in beta.

Best regards.
Fnux


#14

Ah there’s no sound on Windoze VMWare either.

My wonderful wife does have a MacBook pro… At some point I want to look at the VMWare extension and update it. Not promising any timelines, but I will promise to check it works on both Windoze and Macs when I get around to it.


#15

Have you installed vmware_addons and started it by running vmware_tray from Terminal?


#16

Hi Diver,

Sure, I did both as well as starting VMware Addon from the Application menu.

Only the mouse “liberation” from/to OS/X is functional with VMware Fusion and I don’t have to press Shift Cmd to liberate the mouse from the guest.

Nothing else supposed to work when installing the vmware addon is there (i.e. with VMware Fusion Pro).

I’ll try later with Windows 10 and VMware Workstation Pro on a bare metal.

Best regards.
Fnux


#17

Clipboard is working for me in VMware Fusion 10.1.3 (9472307).
Drag and drop is not supported however.


#18

Hi Diver,

So, you are luckier than me.

To be sure of what I’m saying, I just reinstalled Windows 10 on a PC (Fujitsu Stylistic 720, i5, 4 Gb RAM, 256 Gb SSD) and VMware Workstation Pro 12.5.2 (full official pack with its due paid license) and unfortunately after created a Haiku VM, then have it updated and installed the vmware addon package, the clipboard sharing does not work (as with VMware Fusion on OS/X)!

Moreover, there is neither cut nor paste options in the windows menus (right click) and the usual commands Ctrl c and Ctrl v do not give any results either from or towards both the host and the guest.

Also, I may be dumb and rusted but how do you you make clipboard sharing work from/to the guest/host (example of command)?

Moreover, as Haiku is still in an early beta phase, I do not want to make the risk of installing it on a are metal that already has other working systems any more (e.g. both Windows 10 and Linux Mint via grub), especially since all my systems use EFI.

Kind regards.
Fnux


#19

Click on the Leaf menu then go to Desktop applets.
Click on VMware add-ons
You’ll see a blue two square icon appear in the Deskbar
After that, you should be able to use the copy/paste from the clipboard.
If not, click on the icon and make sure Enable clipboard sharing has a check mark next to it.

Capture

The dual blue box thing you should click on is under the menu, but this is the VMW Add-ons menu:
Capture2


#20

Also, don’t forget in Haiku it’s ALT-C and ALT-V.