Haiku hrev53545 network issue

Hello there.
I had some problems with sound on my thinkpad x220 and haiku stable so i desided to try a nightly build. But get another strange behaviour. Succesfully connected to my WiFi, added google dns, able to ping internet domain names, and stuff, BUT have no access via http. Depot wont load packages, curl wont load pages ( timeout ), browser dont work too.

Any advice appreciated.

Okaay, i’ve tried to change MTU and it worked! But worked for like a minute, lol. After changing MTU to 1480 and reconnecting to Wifi i could CURL google page. But just once. So i lowered mtu once again and nothing happened.

Is there a way to set MTU globally for interface on boot ?

Aaaaand i did it! The problem is that on my router were enabled both 20 and 40 Mhz range. And i noticed that my Haiku laptop connected with 40Mhz. So i just disabled 40Mhz option and everything is working now.
Feeling good.


thanks for describe your problem and how to solve. maybe other have similar situation can be helped by your posting… :+1:

1 Like

It’s an interesting experience, but it would be even more interesting if someone could explain how a 40Mhz wifi connection could disable one kind of traffic (HTTP) but not others (“ping internet domain names, and stuff”.)

I’m interested because I vaguely remember something like this when I installed x86_64 Haiku hrev53512 on a laptop - and the problem was eventually resolved, but I can’t recall that it was because of anything I did. I naturally suspected that my problem might be more trouble with IPv6 - it’s useless here and Haiku applications only waste time with fruitless attempts to use it - but I didn’t manage to make a clear case for this.