Haiku gets stuck at splash screen, no icons appear on intel mac pro

I have been trying to install haiku on my macbook pro mid 2012, i7 version and it gets stuck at the splash screen. I have waited for a while but no icons appear. We have tried some suggestions, such as pressing both shift and space, but it makes no difference. Haiku seems like such a cool os, but it sucks that it just wont boot. Any advice would be very helpful, thank you!

we have tried a different mac computer, a 2009 21inch imac, and that booted haiku just fine, so we are not sure why this macbook pro is having issues.

Most likely the GPU is causing this problem, I’d suggest installing rEFInd (see here) which should fix the keyboard issue that prevents you from summoning the boot menu. Once you get the boot menu, select the fail safe graphic driver to boot Haiku in VESA (framebuffer, actually).
If that doesn’t fix the issue, the only solution would probably be flashing the internal SSD directly or booting via a Haiku DVD.