Haiku EFI install on Huawei Mate S unbootable

I have successfully installed the latest Haiku version on my Huawei Mate S desktop PC, but am unable to boot the system. I have tried following the guide as well as initiating an install process with a Linux distro (Q4OS) to try to get the EFIBOOT partition that way. Nothing seems to work, and I have run out of ideas.


Help would be appreciated.

As a new user, I am only allowed to include one screenshot with a post for some reason, here is the other:

if you did not add an efi boot entry for the file you can do so wirh efi shell or another OS like linux.

alternatively rename the file to the same name it has on the efi partition of the installation medium.

1 Like

As stated, I tried following the uefi guide for installing. That means that I copied haiku_loader.efi to EFIBOOT pictured above into EFI → BOOT. My computer doesn’t appear to have an efi shell included in the UEFI BIOS. I have tried booting into a Q4OS (Debian) install USB pen drive, and installed efibootmgr. I have mounted/dev/nvme0n1p1 at mount point /haiku From there, I am somewhat unclear. I can run efibootmgr, and as far as I understand, the “-c” option will create a new entry, while “-p” will refer to the partition number that Haiku is on, and “-d” would refer to the disk that Haiku is on.

Currently, efibootmgr gives me the following:

$ efibootmgr
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0002,0001,2001,2002,2003
Boot0000* EFI USB Device (VendorCoProductCode)
Boot0001* Linpus lite
Boot0002* Linux
Boot2001* EFI USB Device
Boot2003* EFI Network
Boot2004* Huawei Firmware Update Program

Should I use the following?

$ efibootmgr -c -d /dev/nvme0n1p1

I am unsure if booting from a live USB drive changes the nvme drive number so that it will not correctly identify where Haiku is installed…

OK, it appears that I followed the instructions correctly. the only thing that I needed to do was to take the /dev/nvme0n1p1/EFI/BOOT/haiku_loader.efi file and rename it to/dev/nvme0n1p1/EFI/BOOT/BOOTX64.EFI.

The only thing that I am wondering, is whether my “efiboot” partition should appear mounted on the desktop for every session.

Normaly it shoudn’t.

It isn’t needed. Try to unmount it and reboot. If it is mounted again then check options in Tracker. You can either mount all disks, all Haiku disks or previously mounted disks. You certainly have opted for first option.
Actually, these should be reworded since this is more about volumes than disks.

1 Like

Unmounting and rebooting solved the issue. Many thanks.