Haiku detects my Wifi card as ethernet device

Hello! I booted the latest nighty release (hrev44190), wich includes wpa_supplicant, from a USB stick. In network preferences, I can see both interfaces my computer has (Intel Wifi Link 5100 and Marvell Yukon 88E8055), and it detects all the wifi networks. It didn’t gave me the option to put the password (WPA), so I tried to connect through the Terminal. ifconfig said that my Intel Wifi 5100 (using the iprowifi4965 driver) was an ethernet device, so I couldn’t connect to my network from Terminal neither. How can I connect to my wifi network?

Just a wild guess - try to disable marvel_yukon by renaming it to marvel_yukon.disabled.