Haiku booted! on my hardware! there was an issue though

I got haiku to boot on my dual 300hmz PII tyan motherboard!! It did require that I turn off DMA in the boot manager but that was it… not entirely sure why since i think the motherboard supports DMA IIRC

The boot error with DMA on…

running haiku!!!

Inside my case

Cool pictures! Weird bug though, BeOS R5 boots with HDD DMA enabled?

Ow!! amazing machine!! I want to have one!! :’(

Please explain how you got it to work? I have a couple systems i’m dying to test this on! Thanks.

well i haven’t been able to boot any BeOS 5 CDs that i have burned perhaps I burned them incorrectly since i am not used to the bin/cue format…

But that is Haiku running there with DMA disabled … also that is not the monitor i use for it i use a homely 800x600 max monitor on my Haiku box… OH one more thing i just booted a copy of puppy linux on the cd drive and dd the disk image directly to /dev/hda like this
dd if=./haiku.image of=/dev/hda

remember the disk image will only work on a hard disk that is setup as hda or the primary master on your ide chain otherwise as far as i can tell you would have to have linux already installed and the svn of haiku so you could build the makebootable program that will make a different partition bootable but I am not even sure that would work…

Ok, you need to give more hardware info.

What chipset is your motherboard? ie: Intel LX, Intel BX, VIA KT133, SiS 621, etc.
Give the brand, model & size of your hard drive too.

I believe Haiku supports DMA. I never had to turn it off to boot Haiku. So, the issue would then point to either your motherboard or hard drive - both must support it.

Some motherboards do not support DMA correctly.

Check your BIOS to see if DMA is turned on or if you can choose a slower DMA mode.ie: UDMA 2

Newer hard drives also set a DMA mode ( UDMA 5/6 ) which is higher than what older motherboards can support ( which is UDMA 2 - 33MB/s ). Once I know your hardware, I can advise better.

To burn cue/bin I use Nero. Tell it to burn from an image file, load the cue file and then burn. You should be able to do the same on Linux. The cue file gives instructions on how to burn the bin ( image ) file.

I use linux nero… not a good option it was not the fact that i could not burn a disk but that i was not sure which boot floppy image to use for instance the disk would boot but would hang somewhere during the boot process at the graphical point. prehaps i should have explained about the cd burning issue a little better.

the motherboard is a tyan http://www.tyan.com/archive/products/html/thunder2atx.html

as you can see it supports udma/33

and my mistake those are usb 1.2 ports… X.x i had mentally assumed 1.0 without the revision but meh…

and it is an olp3sa3 not sa2 but I am pretty sure the driver is the same

The hard disk is a IBM OEM drive… model: DJNA-370910
several sites say that it is udma/66 capable

one other thought haiku does get pretty far along in the boot process and is seems to be able to read the disk I mean how else would it get this far?

EDIT(one of many): i think i am kinda slow today :slight_smile: must be that the mobo doesn’t like the udma/66 drive … is it possible to get udma/33 on this drive?

Ok, I checked your motherboard out.

It uses an Intel LX chipset. Supports UDMA/33.

Your hard drive is 9GB, 7200rpm & supports UDMA/66. Deskstar 22GXP model.

Back in the day I faced the same problem. The hard drive would try to run at 66 MB/s when the motherboard could only support 33MB/s. It was a Maxtor drive and there was software to set the UDMA mode.

Seagate SATA drives use a jumper to set 1.5 (SATA I) vs 3Gb/s (SATA II).

Your drive is now supported by Hitachi.
You’ll find information for it here:

To change UDMA mode you’ll need the Feature Tool:

You should also look through the Feature Tool user guide. Drive Fitness Test would be good to test out your hard drive to be sure it is running well. I’m sure things will work once you match up the UDMA mode with your motherboard.