Haiku Boot Menu

Hi. I installed Windows 10 to a Lenovo ThinkCentre m800. I wanted to install Haiku (32 and 64 bit) alongside Windows. When I install Haiku (64) onto a partition I made for it, and try to “Set Up Boot Menu” in the installer, the system disk shows as being “incompatible”.

Why does it say that? Is there a way I can manually fix or install the boot menu?

I also attempted to install Ubuntu manually, to see if I could add it to the boot menu. But I have no intention of using it and was doing it to test, so doesn’t have to be a part of what I’m doing right now.

AFAIK, Haiku’s boot menu only works if your drive uses MBR style for its partitions. Maybe you’re using GPT on yours?

If your machine allows you to use MBR/BIOS/Legacy boot (instead of UEFI), you can try re-initializing the whole disk in MBR before installing your OSes.

Of course, only do this if you don’t mind your data being wiped out!

For UEFI boot, the usual recommendation seems to be to use “rEFInd” if you plant to multiboot).


Hmm. That’s kind of obnoxious. I don’t think it would be best to have Windows 10 installed on MBR. It would be nice if I could use Haiku Boot Menu.


Alright. I gave in for a little bit. I installed rEFInd. I got Windows 10 and Ubuntu on the list normally. After installing Haiku, I had to copy the haiku_loader.efi from the platform loaders folder to get it to show up in rEFInd menu. But when selected, instead of booting into Haiku, It goes into the Haiku boot options menu, and there are two “HaikuHD” options for boot volume. I have to manually pick either one and then say continue booting to boot.

I would like to get this working, but also this could’ve been a non issue if Haiku stood by their boot manager. I shouldn’t have to install third-party tools, and it doesn’t make sense to have such a simple and easy to use boot menu (Haiku/BeOS) if I can only ever have Haiku as the only option.

1 Like

I also attempted using Grub, and following the instructions for that. Minus the EFIBOOT partition. I already have an efi partition. Couldn’t get that working with Haiku install instructions or with Grub Customizer in Ubuntu. I’ll experiment more some other time though.

The Haiku boot menu isn’t supposed to show up every time. It is not a boot manager but rather a debug menu like what you get on windows if you press F6? (can’t remember excat Fx key…) and that’s why you won’t see other OS there.


It means the bootloader was not sure which partition to boot.

Usually this can be caused by:

  • If you use MBR/Intel partition style, your Haiku partition doesn’t have the “BeOS” type in the partition header (this is different than the filesystem used to format it), or the partition isn’t set as active.
  • If you use GPT partition style, your Haiku partition does not have the Haiku GUID and instead has some other.

This should be fixable with DriveSetup or other partitioning tools.

From the boot menu you can also check the bootloader log, which may tell you more about what happened exactly and why the bootloader wasn’t able to select a partition.


Yeah. I don’t know. Issue seems to be resolved when I reinstalled and am trying to use grub now. Still need to use usb to boot up. Currently trying to configure grub the right way.

Making a proper bootloader for EFI , will be good. I don’t know if there is a proposal for this.

1 Like

We already have a proper bootloader for EFI.

For multiboot in sn efi enviromemt there is no additional bootloader required.

If your efi firmware is defective or barrbones or you widh to be promptef you can use rEFInd, in any case we don’t need any additional loader.

For multiboot using efi , i refer. :slight_smile:

1 Like

In that case either your firmware provides this, or you can use rEFInd. : )

1 Like

The current boot loader has worked for me sometimes. Usually only when installing Haiku only. If I wanted to install Haiku on my Windows 10 machine, I could not install the boot menu. As it says the drive is “incompatible”. Maybe something to enhance with the boot menu.

1 Like

Alright. I got it working. I just put the loader in the windows efi/Microsoft/Boot folder and duplicated the windows grub entry. Then I just changed the path name. I still have the duplicate boot options, and am unsure of cause. What exactly does the boot menu see file wise?

rEFInd does a good job of this, but it would be nice if the BootManager application would offer to install and configure it when it detects a system running on EFI.


Is there something different about the bootloader for 32-bit Haiku? As far as I can tell, I did the same steps for 64 and 32 bit, but can’t get 32 bit bootable. I can install from usb, but then no seeming ability to boot into it.

I wonder if there is some overarching bug here. I tried installing 32 bit on QEMU and it wasn’t bootable out of the box either.

FWIW, I fixed it by setting up a boot menu using the Installer. I didn’t need to do this for the 64 bit version. I doubt doing things this way would be a good idea for your situation since you’re on GPT.

1 Like

The overarching theme is user errors caused by several manual steps being needed for a succesful install. And people going “I know this!” and trying to do it without carefully reading the documentation.

1 Like

After reading the installation guide, it doesn’t seem I made any errors in the installation process. Though, unless I were to repeat the installation process, I can’t know for certain.

I have not actually encountered any “errors” with the boot process. However, with every machine (couple dozen) that I have installed Haiku on, both 32-bit and 64-bit, the process has been different. Most of my issues seem to result of trying to incorporate Haiku alongside other operating systems. I have only had an issue once where I couldn’t get Haiku working by wiping drive and installing as the only OS. I didn’t pursue that though because it was not a system I cared to use anyway.

Currently my setup is a GPT partitioned drive, with an fat32 EFI partition, NTFS Windows partition, EXT4 Ubuntu partition, and 2 BFS partitions. I believe I formatted them as BFS, marked as active, 2048 block size, enabled query support, both the same way. I installed 64-bit and 32-bit the same way. I have 2 options in the boot screen to pick a boot volume: HaikuHD and HaikuHD (same partition). The BeHD partition is not visible as a boot volume from either USB boot drive I use.

It would be nice if the Haiku Boot Menu was more robust. I don’t enjoy trying to customize grub or rEFInd. My best system for Haiku has been my Thinkpad T42P. I actually installed the BeOS boot menu for that, and was able to include Windows, Haiku, and BeOS in the boot menu.