Haiku Beginner. Sound and Wifi Programs Support

I have downloaded and installed the Nightly Image hrev50649 (x86 GCC 2 Hybrid) on my SSD. I have a GUID Partition Table (GPT). And I successfully booted the Haiku Partition using Grub (BIOS Legacy Mode).

The size of installation was about 300 MB. I have a couple of Questions

  1. I played a Video. The Video was OK but there was NO Sound. How to find the Sound Driver or may be if there is any possibility of porting it from BSD or Linux etc ?
  2. WiFi was not working. How to find the WiFi Driver ? I don’t have Ethernet Router so I cannot check the Ethernet.
  3. There was a warning regarding the Nightly Image that Data Corruption may occur etc etc. So is this Possible Data Corruption valid to Haiku Partition only or it can harm data on Other Partitions too (Assuming I am mounting the Other Filesystems as Read-Only).
  4. From where can I find Apps/Programs etc for Haiku ? And how much size should I allocate for Haiku Partition assuming a normal set of Programs for a regular Computer User? Currently I was just testing so I installed it on a 2GB Partition.


Hello, and welcome! :slight_smile: I’m not a developer, just an user with a bit of experience. I will try to help you with your problems.

First, to install apps, you can use the HaikuDepot app that are included in your Haiku instalation. Inside HaikuDepot, you also could find the OpenSound package. This package include several sound drivers. With a little luck, probably your sound chipset is supported.

About the “Data Corruption”, the warning is related mainly to the Haiku filesystem. If you mount the other filesystems as “read only” you will not have any issues. I had been using Haiku since several years, and didn’t have any problem on the another partitions.

If you need to move data between Haiku and other S.O., I guess the best is to create another partition with a filesystem that both S.O. can read and write (for example, FAT32) and use it as a sharing disc. In this way, you don’t need to mount as “read & write” your main Windows / Linux partition.

Finally, about your partition size, I guess is a bit small. Try to use a 8 GB instead.

Sorry, but I can’t help you with your WiFi issue… I still use a wired conection :smiley:

Welcome, areeb!

I, too, mount non-BFS partitions read-only. As my fallback OS is Linux, I don’t need a special FAT32 partition for file-exchanges, as (most current) Linux distros can mount BFS partitions read-only as well.

With regard to partition size, with today’s hardware it hardly makes a difference if you use 3, 5 or 8 GB. 8 GB should be more than enough even if you install a great number of packages. More important is to use a separate partition for your data (and do make regular backups for the important stuff!).

For your connection problem, have a look at the Wireless workshop to see if your chipset is among the supported hardware. If it’s only firmware that has to be downloaded/installed, have a look at the tip at the bottom how to download from another OS with a provided bash script.

Using OpenSound may need to blacklist the non-working driver, I don’t know…

Thanks for the support.
I checked the Wireless Workshop and also the list of supported WiFi Hardware.
I have Atheros AR95x Wifi Device and as per the list of supported WiFi Hardware, almost every Atheros chipset is supported.
I also tried


Downloaded the Zip archive from Ubuntu and executed the script.
I used Expander to see the list of firmwares, but it only had Broadcom and Marvel.
So what to do for the Atheros Drivers ?

If you type “listdev” in Terminal, you can look for the exact vendor and device ID. With those you can look since when (if yet) your chipset is supported by FreeBSD.
Haiku has a compatibility layer for FreeBSD network drivers, which is currently limited to the drivers available for FreeBSD 9.3. So you may be out of luck for now…

I have not used FreeBSD 9.3. But I have used FreeBSD 10.3. I had WiFi support for my Card for 10.3, but the network kept on disconnecting after a couple of minutes. Now I am on FreeBSD 11.0. In this version, it has stable driver for my WiFi Card. So can the driver from version 11.0 be used ?

If your wifi chipset is not supported, here is a workaround until it is:

My Haiku desktop machine does not have a wifi card. But wifi extenders are fairly cheap (you may be able to pick one up even cheaper on EBay) and mine happens to have an Ethernet port. Most of them do

So the extender picks up my wifi network and then a short ethernet wire takes the signal to my Haiku box. Not great as a mobile solution (mine is a desktop machine, so I don’t care) but it does work perfectly for me. As far as Haiku is concerned it is linked to a normal wired connection.

Probably. But only after Haiku’s network compatibility layer for FreeBSD is updated. It’s on everybody’s wishlist, of course, but currently nobody has the time for it, AFAIK. Until then we’re limited to FreeBSD 9.3 drivers.

if you are a skilled dev… you could also port the new wifistack from freebsd over to haiku.
If you can read german there is a verry good document wich would help :slight_smile:

Based on your screenshots, here are the details:

I can see the files, atheroswifi in the path system/add-ons/kernel/drivers/dev/net/

The results of listdev also shows my WiFi Controller.

But the Network Status applet shows disconnected.

The screenshot also shows the results of install-wifi-firmwares.sh

The install-wifi-firmwares.sh can’t work, of course, because you don’t have a working network. And for your atheros you don’t need downloaded firmware anyway.
The atheroswifi in /system/add-ons/kernel/drivers/dev/net/ is only the driver, it doesn’t mean it’s actually used.
You could do a “listimage | grep atheros” to see if the atheros driver is loaded. It probably isn’t, as you say that FreeBSD 9.3 doesn’t support your chipset either. Or do you see /dev/net/atheroswifi/0 when you right-click the NetworkStatus icon in the Deskbar tray?

This is what I am getting on listimage | grep atheros.
And when I right-click the Network Status applet, I have ‘Open Network Preferences’ only.
and when I select ‘Open Network Preferences’ I get the Network Window shown in the screenshot

FreeBsd 10.3 uses ‘ath0’ to detec my WiFi. I am not sure about FreeBSD 9.3 that whether it supports my WiFi Card or not, because I have not used FreebSD 9.3 version,

The listimage output only returns the grep command running, looking for “atheros”. So no, the atheros driver isn’t running, your wifi chipset is not detected. From what I’ve seen when searching FreeBSD forums, it looks like FreeBSD 9.3 didn’t work with your AR9565.
Sorry to say, but you’re out of luck until Haiku’s compatibilty layer is updated. Maybe you can find another cheap wifi card that works.

Work fine - Intel Centrino Advanced N 6235

Hmm. And my Ethernet is also Atheros so that won’t be working either then.
I have a D-Link Usb Wifi Card. DWA-121. Will that work.
Or, is there is any other way that I can use the driver from FreeBSD 11.0 ? I can recompile the Haiku Source Code, if required for this.

Otherwise, without internet access, how can I use HaikuDepot to install Programs ?

I probably cannot change my WiFi Card. One, because I am a bit afraid of getting into the hardware. and secondly that I have read that for my Model, I have to patch the BIOS to use any other WiFi Card. (Laptop Model Lenovo G510)

Nope, USB dongles don’t work yet under Haiku.

We need an updated compatibilty layer… So, no.

[quote]Otherwise, without internet access, how can I use HaikuDepot to install Programs ?
You can download the packages from another OS by going to the Haiku Depot Webserver. But running without internet… Personally, I’d go with running Haiku in Virtualbox.

Well, not easily at least.

The process would be something like this:

  1. Locate the driver sources in FreeBSD (I would suggest FreeBSD 10 or as close as you can to FreeBSD 9, to get a driver more similar to what we expect) - the drivers in FreeBSD have 3 or 4 letter names and are located in https://github.com/freebsd/freebsd/tree/master/sys/dev/ . Guess which one you need.
  2. Import the sources in Haiku. They have slightly more readable name and are sorted by device type: http://cgit.haiku-os.org/haiku/tree/src/add-ons/kernel/drivers/network
  3. Adjust jamfiles for your driver. If you updated an existing driver, make sure all sources are listed, if you added a new driver, you need to write a Jamfile for it, add it to the parent dir Jamfile, and write a “glue.c” to plug it to our network driver system.
  4. Try to build your driver (“jam -q atheros” or whatever name it has). This will fail, because the FreeBSD code uses some functions we don’t implement yet (or if it works, you are lucky, no updates to the compatibility layer were actually needed)
  5. Analyze the failure, write or rename the modified functions, etc, until it builds.
  6. Add your driver to an Haiku image and test it, it may work, or require further debugging.

On Haiku IRC channel you can find some people who are also involved in FreeBSD, and can provide some more detailed help.


hmmm… Well I have installed Haiku on VMWare now.
But the performance on Vmware is very very slow and buggy.
It is obviously because the OS is emulated.
I have not tried Virtualbox yet.

Seems like I have to wait for the compatibility layer to be updated.
How much time, we can expect btw for the update of the compatibility layer ?

I do have Haiku installed on real Partition as well.