Haiku Activity & Contract Report, June 2022: 802.11ac WiFi | Haiku Project

As is the usual way of things, the monthly Activity Report is hereby combined with my Contract Report. Since there is just so much to report this month, instead of the usual chronological order by section, instead things will be loosely sorted by “size”.

This is a companion discussion topic for the original entry at https://www.haiku-os.org/blog/waddlesplash/2022-07-09_haiku_activity_contract_report_june_2022/

19 posts were split to a new topic: Fix QtWebEngine or work on WebKit?

Ok now the EFI Loader boots the system but with black screen and that’s not a problem related yo radeon_hd driver because when i boot in legacy Mode the driver works correctly without black screen (i am using a Radeon rx460).

This is actually probably related to the radeon_hd driver; it behaves differently in legacy vs. EFI boot environments.

There are actually fixes for this that were merged in recent commits from @kallisti5 that might allow EFI boots to at least get to the desktop, though with the fallback framebuffer driver.

It’s good to know that i’ll test a newer release even on APUs because i have a ryzen 5 3400G. Thanks for the advice.

I always thought FreeBSD was the one implementing things first, then OpenBSD, then NetBSD. Looks like I’m being corrected of false asumptions! Anyways, amazing work.

It used to be so (generally speaking, there are a lot of exceptions), but these things change as developers come and go. FreeBSD made the choice to use more and more Linux code and try to get it ported, maybe it wasn’t the best choice. OpenBSD decided to write the drivers “natively” from scratch, and in the end they got an usable result a bit faster than FreeBSD this time.


Just want to thank all the developers for their hard work in getting the project to this point. I do not try it out on VMs, preferring to use real hardware instead and recently fixed my grub2 boot entry so I could take another try. Once I booted up I was able to connect to my WiFi network and run the software updater. My laptop is a Toshiba C55 and I have not seen any issues with hardware (sound works as does usb and obviously WiFi). Now that I’m all updated the system seems quite stable. I have yet to see a kernel panic even though I left GLTeapot running for 8 hours or so while I was sleeping.

WebPositive is still crashing a lot and has been quite frustrating to use because of it’s slowness. I use YouTube to asses browsers and the experience with WebPositive is not good Everything else seems very responsive in comparison. I’m sure the developers are aware of the issues and maybe now that the rest of the system appears to be working so well they can focus more on hunting the issues in WebPositive. Once Haiku has a working, full featured web browser I think it will be ready for prime time (I’ll be able to use it as my “daily driver”).

Keep up the great work guys (and gals)!


Nice report, as always. I only don’t understand: the sorting by “size” is done ascending or descending? All the news (802.11ac, network and radeon drivers, filesystems support) are very exciting and more-or-less equally important / hard / required :slight_smile:

It was amazing read the report about enhancement and fixes enlisted.
Me, who checked also development entries meanwhile and tickets as well, was also interesting to read about long awaiting tickets closed from good old days.
I also checks tickets by Roadmap to see how those are progressed related to percentage of whole numbers per releases, by staus as blocking and critical and ages since those were opened. Is it assigned or not, read the notes in them.
Well you should also read them to understand difficulties of fixing, as some problems reported as fixed and some of them was reopened as new nightlies caused again the same error. Sometimes the new problem not reproducible and that cause the error cannot be fixed as the developers cannot trigger/simulate in their environment.
Also very problematic a rare hardware or config to be supported - whether how many ticket can be under R1 roadmap that is old and reporter do not use that one since it was reported ?..
Of course I understand it was right to those remaining and should discover what could happen to cause that error and this way not simply closed as such HW/SW can be used by another person and as well can reveal some still existing hidden error that just comes out in case of specific circumstances which are might be turns out quite often nowadays.
However how much can be the reduced number of really alive problems and enhancement request among them ?
Just me myself experienced strange built-in restrictions of USB SD card readers and SD/micro SD cards (as thumb drives) when I tried to boot a Fujitsu Siemens laptop recently – replaced my P4 DELL that booted fine but started to failing and now crashes even during BIOS config – that way I cannot use it anymore.
This way I do not open ticket about Fu-Si laptop boot failure as I cannot exclude that image or SD card availability problems during boot.
Unfortunately it does matter which program used and how was written the image onto drives as I had learn t- so maybe I caused my unsuccessfulness. :wink:

Anyway I spent my hours well - reading tickets, and development remarks where there were available in committed changes.

Thanks for your efforts ! :smiley:


I tested my self with todays nighly build and booting from UEFI is a black screen like it was.

I had an intermittent WiFi connection before, sometimes it would connect, sometimes it wouldn’t on my iprowifi4965, but now it connects every time.


is nvvm storage working ?

There has been NVMe support for three years.. It should be working

I’ll have to retest with my hardware again, if it’s not working I’ll get a big ticket in

i have a wifi chip that is supported on the RTWN RTL8723AE from OpenBsd and i see that source are on the haiku too, why it is not detecting my wifi card?