Haiku 64bit (nightly) runs on Lenovo Yoga 2 Pro 13'' ultrabook!


#1

All,

I am very excited to report that latest nightly builds run for the first time on my Lenovo ultrabook !! (build details will follow).
I think that USB 3.0 fixes made the difference. Previously the best I could get was KDL just after rendering the desktop.
Haiku flies as expected !
Thank you all for making this a reality!
Post is a little long but I need to give the details…

Hardware details
Total 4 i7 cores at 2Ghz (think that I saw somewhere Haiku reporting them as 2,5Ghz), 8Gb RAM, 512Gb SSD, Intel integrated GPU and “retina” screen with 3200x1800 max resolution.

What works (on hrev52989 which proved most stable till now and on which I am writing this):

  1. I am EFI booting it with only Haiku installed on it. Setup manually FAT32 parition and copied boot loader. Originally booted from USB 3 port.

  2. Video card correctly detected as Intel HD/Iris (Haswell mobile) :slight_smile:
    Lots of resolutions up to 1920x1200. I use it on 1920x1080 to retain correct aspect ratio for the screen. I have changed the font size to 20 and UI is totally usable with very few glitches on some apps. Most of the main system behaves totally correct (refering to UI layout, control placement e.t.c).

  3. HD Audio sound works both on speakers and on line out (very happy !)

  4. I have network fully working through USB-to-ethernet adapter. Based on reading on another thread I grabbed a TP-link that uses a Realtec chip. Worked immediatelly.

  5. Keyboard back light somehow works and I am able to turn it on/off !

  6. Should note that my current configuration uses an external USB hub connected to the USB2 port (laptop has only 2 USB ports). On the hub I have attached the USB-ethernet adapter and an Apple aluminum keyboard (to which I have attached the mouse).

  7. Touchpad works IF I don’t have a mouse attached. But movement is slow and cannot make it faster from preferences. Maybe related to screen resolution. Don’t know.

What didn’t work

  1. Was not able to make wireless work although I tried hard. It finds the chip (idualwifi7260) and most of the times list networks. But something fails on negotiation. It worked only one time, don’t know how. All other tries failed (and I did many of them). I think there is a ticket related to it. Could attach my syslog if it makes sense.

  2. Touch screen doesn’t work but didn’t expect so (listusb reports it though). Anyway I am using the device as a laptop and not as a tablet.

  3. KeymapSwitcher doesn’t work and this is my main problem. Languages are listed OK and all settings are correct. Until now I had no problem with KeymapSwitcher with exact same settings on other 2 machines (old Intel iMac and old Compaq laptop). Trying to change between English and Greek. Tested with/without external keyboard and behavior is the same. Sometimes the system boots and writes English, no way to change it, sometimes the other way around (Greek). Is there a known regression on latest nightlies?

  4. USB-to-ethernet adapter doesn’t work on the USB 3 port.

Nightly build remarks

  1. As mentioned above I get the most stable behavior on hrev52989.

  2. Booting broke on hrev52989-1 and hrev52992-1 at least. Something related to XHCI and mutexes I think, didn’t save info. Works again now on the very latest. I thought it was hrev53000 but in my states folder I find hrev52993-1, so I am a little confused regarding the exact latest revision…sorry…

  3. So, on the latest revision on which I was able to boot again and which I installed 2 hours ago, USB-to-ethernet adapter doesn’t work. Stays on “configuring…”.

I hope I didn’t forget anything.
Any advice on KeymapSwitcher front will be highly appreciated. This is the only blocker to fully use this machine.

Thanks again the devs and everyone in the community.


#2

There is a ticket about this, but previously it KDLed with that “XHCI and mutexes” problem. Indeed I fixed that which is why it’s gone :). A syslog attached to that ticket will be very helpful in investigating the usb_ecm problems.

AFAIK nothing should have changed. @Diver or @humdinger may be able to help here…


#3

I normally don’t use KeymapSwitcher, but just gave it a quick try. It works here with hrev52990 (32bit) and keymapswitcher-1.2.7.11-8-x86_gcc2.hpkg, but only if the replicant is installed in the Deskbar.


#4

Just added comment and attached my syslog on ticket #14959. I hope it was the correct one. Couldn’t use the same username on Trac (something about policy) so I am fotisk there…
I see the ticket marked as closed though. Maybe you already fixed something? I think I will try again with 53001 :slight_smile:


#5

I always install it on Deskbar. Just updated another older laptop to hrev53001 (always 64bit) and works OK there. I will do another test here because my configuration is somewhat special, I am using big font sizes due to high resolution on small screen. I will check if there is any relation… I will also update this one to 53001 to compare same versions.


#6

No luck yet. Still happens on hrev53001. Confirmed that font size is not the problem. Deskbar icon does change its state when pressed or when using the shortcut. But input language doesn’t change; need to investigate more…


#7

photos, more photos


#8

Close the deskbar replicant remove the /boot/home/config/settings/Key_map file, restart the app and see if that helps.


#9

Didn’t work :frowning: but thanks for the tip anyway!

I am checking and comparing with another laptop where it works OK.
I tend to believe that something goes wrong with my installation.
For example, although I uninstalled keymapswitcher it’s still there on the system and runs…
I suspect something is happening with the package system, not necessarilly a bug but the way I am using it. I am booting a previous state of the system where my USB-ethernet adapter works. I have done various backs and forths bewteen latest state and the working one; possibly installing some apps in between…

I saw that keymapswitcher hasn’t changed for years so it’s highly unlikely that it’s the actual cause. Some sequence of events must have brought my system to that state. If nothing else works I may need to re-install :frowning:


#10

If you boot an older state, you get the packages that were installed in that older state. No matter what you add or remove or update to the current state, older states are frozen and never changed.


#11

Thanks a lot!
That makes sense. Which means that I need to do all my experiments on the latest state.


#12

Boot to latest state. Removed package KeymapSwitcher. Now removed OK. Verified with query.
Pulled it from github and built it locally. I have the same behavior. Also removed again the settings file.
I want to debug it. The local build I did produced release build so I don’t see the source code in debugger.
How I can make a debug build?


#13

Add -g to CFLAGS/CXXFLAGS, i assume.

I don’t know about KeyboardSwitcher (thanks for god i never had to use anything like that), but i need to warn you about having more than one instance lying around from the same BeOS/Haiku software. If it is installed into the Deskbar, at reboot Haiku will start it trough its filetype (actually doing a query for it, so it wil lfind even if you moved it around). You won’t be sure if it is from the package or the one, which you built. That can make plenty headache. Make sure there is only one instance exists on BFS disks.


#14

Yes, I already encountered that. I uninstalled the official package in order to be clear that I am using the one I built. But I didn’t know that it will find it automatically through a query! Thanks for the hint and giving me the big picture :slight_smile:

I will try to find out where the build flags are set.