Haiku 4.1 Actually Works on Parallels 7

Hello everyone, I purchased months ago Parallels 7 moving away from Virtual Box, but unfortunately Haiku never worked. Some people said “you know just download Virtual Box” but it wasn’t an option, I didn’t purchased Parallels to use yet another virtualization software. Anyway I tried booting from the ISO but it does’t work It just stays there trying to load the OS into memory I guess.

Then I read a post in the Parallels forums about someone complaining that networking wasn’t working on Parallels 8 but since I am stuck at 7 (didn’t qualify for free upgrade for 1 month :’( ) I downloaded a demo of Parallels 8 and the Haiku .image and used this instructions :

bunzip2 haiku.image.bz2
dd if=/dev/zero of=haiku.image bs=1024 count=1 conv=notrunc seek=408600
mv haiku.image haiku.hdd

then created a new virtual machine with that hard drive and to my surprise it boots Yay! now I wen’t back to Parallels 7 and after two failed boots it is now fully booting even with USB and network enabled.

I have to try to do the same instructions straight from Parallels 7 and try to do some internet browsing. Funny thing is that a couple of days ago I ordered a PC just to Install Haiku on it, and it is now in transit to my house.

This is my first message from Haiku A4.1 runing over Parallels with network enabled!

Ok so I tried to do the same straight from Parallels 7 and it doesn’t work. It appears it only works from parallels 8 only but the image works on Parallels 7. The hard drive reports a size of around 700MB altough the configuration says 8.0GB I gues Parallels doesn’t understand BeFS at all ( no suprises there). I’m going to try to create a second fixed size hard drive and install it from there.

Yeah that would be because the image you dded is that size… that can happen if you dd it to a real parition also. But it will be fine if you create a new disk and install to that and then make that the primary disk I believe. I usually end up repurposing my swap partition as a temporary befs install partition whenever I update. (my laptop has no cdrom so yeah)

Yes, I just did that and it works. Anyway my PC arrives this Tuesday although without HD nor RAM and I plan to install it there.